Binary Radio Pulsar Search (Parkes PMPS XT) (BRP6) ending

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 3777
Credit: 164186803
RAC: 42250
Topic 201265

The server status page shows about 30d left for BRP6, but this progress counter - as usual - points to the time when the results are expected to be returned. We will run out of BRP6 work to send about a week before.

The Binary Radio Pulsar Search in Parkes data will not be extended. We do have a pile of Arecibo beams that we will feed to the GPUs (BRP4G), and I am working on a GPU version of the Gamma-Ray pulsar search, I hope to be done with it before we run out of these.

BM

Mumak
Joined: 26 Feb 13
Posts: 310
Credit: 1287690960
RAC: 685534

Thanks for the

Thanks for the information.
Are there any plans for a CUDA 5.5 version of BRP4G ?

-----

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 3777
Credit: 164186803
RAC: 42250

Mumak wrote:Are there any

Mumak wrote:

Are there any plans for a CUDA 5.5 version of BRP4G ?

The application is identical, it just seems that the CUDA 5.5 app version was never published for BRP4G, probably because usually BRP4G only ran for a few days or weeks max.

Fixed.

BM

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 236
Credit: 198075877
RAC: 375067

Wondered what was going on

Wondered what was going on since I just picked up the new BRP4G CUDA 55 1.56 application and new work.

BoincStats

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 238
Credit: 143039814
RAC: 1553

The  1.56 (BRP4G-cuda55) are

The  1.56 (BRP4G-cuda55) are running OK on my Linux machines (Ubuntu 16.04), but the four that I have received on my Win7 64-bit machine have all errored out. 

https://einsteinathome.org/host/11368189/tasks/error

These are all running on identical GTX 750 Ti's, not overclocked.  But on my Windows machine, I have two GTX 750 Ti's.  Two work units errored out almost immediately, and the other two after 1 1/2 to 2 minutes. After the first three errors, I rebooted the machine before the fourth one started, but that did not fix it.

It might be something wrong on my machine, but it was running the CUDA 3.2 BRP4G's and the CUDA 5.5 BRP6's OK for almost a week, which is when I started up on this machine again.

archae86
archae86
Joined: 6 Dec 05
Posts: 2295
Credit: 1371059673
RAC: 1117232

Jim1348 wrote:The  1.56

Jim1348 wrote:
The  1.56 (BRP4G-cuda55) are running OK on my Linux machines (Ubuntu 16.04), but the four that I have received on my Win7 64-bit machine have all errored out.

I deliberately started a BRP4G-cuda55 trial on two machines this morning.  The one that has gotten work is a Windows 7 host running a single 750Ti card.  It downloaded four tasks, all four of which promptly errored out.

This machine has been running BRP6-cuda55 reliably.  It was not previously running the non-beta BRP4G.

Hereis the stderr for one of the four tasks--the other look very similar.

Key points:

Outcome: Computation error
Client state: Compute error
Exit status: -1073741819 (0xC0000005) STATUS_ACCESS_VIOLATION
<message>
(unknown error) - exit code -1073741819 (0xc0000005)
 

 

 

Mumak
Joined: 26 Feb 13
Posts: 310
Credit: 1287690960
RAC: 685534

I got a few v1.57

I got a few v1.57 (BRP4G-cuda55) on XP32 machine with 750Ti.
All finished OK, not validated yet.
Run times went from 2600s (cuda32) down to 2000s. Very nice improvement!

Will give it a shot on Tesla K20c.

Update: x64 machines (Win10) are getting v1.56. These have failed for me on all machines.

-----

archae86
archae86
Joined: 6 Dec 05
Posts: 2295
Credit: 1371059673
RAC: 1117232

Bernd Machenschalk wrote:We

Bernd Machenschalk wrote:
We will run out of BRP6 work to send about a week before.
<snip> 

We do have a pile of Arecibo beams that we will feed to the GPUs (BRP4G)

I've not been running BRP4G previous, but in trials today I noticed that the BRP4G-cuda55 work downloaded with a 7-day deadline, unlike the 14-day deadline for recent BRP6-cuda55 work.

Possibly this deadline could be relaxed prudently?

archae86
archae86
Joined: 6 Dec 05
Posts: 2295
Credit: 1371059673
RAC: 1117232

I received three BRP4G-cuda55

I received three BRP4G-cuda55 tasks to a second machine.  This one is a Windows 10 host running two cards, a 1070 and a 1060.

Because of the short deadline for BRP4G work, all three tasks were run promptly after download.  All three errored in less than ten seconds each, with the sparse available evidence in stderr looking the same as the failures on my Windows 7 750Ti machine.

I don't know whether these were assigned to the 1060 or the 1070.  The stderr did not extend to the point where that information is normally recorded.

One representative stderr from the Windows 10 GTX 1070/1060 machine.

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 3777
Credit: 164186803
RAC: 42250

Cuda 5.5 BRP4G Apps disable

Cuda 5.5 BRP4G Apps disable until further notice for analysis.

 

BM

Mumak
Joined: 26 Feb 13
Posts: 310
Credit: 1287690960
RAC: 685534

Oh, that's a shame. I hope

Oh, that's a shame. I hope this will be resolved soon.
Is it possible to at least enable the x86 v1.57 ? That was working well (at least for me).

-----

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.