Win 8

Alex
Alex
Joined: 1 Mar 05
Posts: 449
Credit: 368,513,056
RAC: 215,743
Topic 196703

Hi,
Christmas brought a win8 upgrade DVD.
No question, I tried it today.
Not a good idea, I don't get gpu work now.
I reinstalled the AMD drivers, did not help.
Messages show the following

25.12.2012 09:42:39 | | ATI GPU 0: ATI Radeon HD 5800 series (Cypress) (CAL version 1.4.1741, 1024MB, 991MB available, 3584 GFLOPS peak)
25.12.2012 09:42:39 | | ATI GPU 1: AMD Radeon HD 6x00 series (Sumo) (CAL version 1.4.1741, 512MB, 479MB available, 960 GFLOPS peak)
25.12.2012 09:42:39 | SETI@home | Found app_info.xml; using anonymous platform
25.12.2012 09:42:39 | Albert@Home | Application uses missing CUDA GPU
25.12.2012 09:42:39 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 09:42:39 | Albert@Home | Application uses missing ATI GPU
25.12.2012 09:42:39 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 09:42:39 | Donate@Home | Application uses missing ATI GPU
25.12.2012 09:42:39 | Donate@Home | Application uses missing CUDA GPU
25.12.2012 09:42:39 | Einstein@Home | Application uses missing CUDA GPU
25.12.2012 09:42:39 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 09:42:39 | Einstein@Home | Application uses missing ATI GPU
25.12.2012 09:42:39 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 09:42:39 | Milkyway@Home | Application uses missing ATI GPU
25.12.2012 09:42:39 | Milkyway@Home | Application uses missing CUDA GPU

OK, at the moment the system has no nVidia GPU installed, so this is not the problem.
But it's my A8 system, it has a built-in GPU and a external GPU, both detected by BOINC. But what means the message: Application uses missing ATI GPU ?

BM 7.0.38, Win8 pro x64, AMD A8 APU

I did not a new install, it was a upgrade. System was working good before.

Claggy
Claggy
Joined: 29 Dec 06
Posts: 560
Credit: 2,557,091
RAC: 0

Win 8

Quote:
25.12.2012 09:42:39 | | ATI GPU 0: ATI Radeon HD 5800 series (Cypress) (CAL version 1.4.1741, 1024MB, 991MB available, 3584 GFLOPS peak)
25.12.2012 09:42:39 | | ATI GPU 1: AMD Radeon HD 6x00 series (Sumo) (CAL version 1.4.1741, 512MB, 479MB available, 960 GFLOPS peak)


Please post your Boinc startup messages, the first 20 to 30 lines will do, at the moment your host is only showing support for CAL, and not OpenCL.

Claggy

Alex
Alex
Joined: 1 Mar 05
Posts: 449
Credit: 368,513,056
RAC: 215,743

25.12.2012 11:04:19 | |

25.12.2012 11:04:19 | | Starting BOINC client version 7.0.38 for windows_x86_64
25.12.2012 11:04:19 | | log flags: file_xfer, sched_ops, task
25.12.2012 11:04:19 | | Libraries: libcurl/7.25.0 OpenSSL/1.0.1 zlib/1.2.6
25.12.2012 11:04:19 | | Data directory: C:\ProgramData\BOINC
25.12.2012 11:04:19 | | Running under account alex
25.12.2012 11:04:19 | | Processor: 4 AuthenticAMD AMD A8-3870 APU with Radeon(tm) HD Graphics [Family 18 Model 1 Stepping 0]
25.12.2012 11:04:19 | | Processor: 1.00 MB cache
25.12.2012 11:04:19 | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 htt pni cx16 syscall nx lm svm sse4a osvw ibs skinit wdt page1gb rdtscp 3dnowext 3dnow
25.12.2012 11:04:19 | | OS: Microsoft Windows 8: Professional x64 Edition, (06.02.9200.00)
25.12.2012 11:04:19 | | Memory: 7.50 GB physical, 15.00 GB virtual
25.12.2012 11:04:19 | | Disk: 111.69 GB total, 26.74 GB free
25.12.2012 11:04:19 | | Local time is UTC +1 hours
25.12.2012 11:04:19 | | VirtualBox version: 4.1.22
25.12.2012 11:04:19 | | ATI GPU 0: ATI Radeon HD 5800 series (Cypress) (CAL version 1.4.1741, 1024MB, 991MB available, 2688 GFLOPS peak)
25.12.2012 11:04:19 | | ATI GPU 1: AMD Radeon HD 6x00 series (Sumo) (CAL version 1.4.1741, 512MB, 479MB available, 960 GFLOPS peak)
25.12.2012 11:04:19 | SETI@home | Found app_info.xml; using anonymous platform
25.12.2012 11:04:19 | Albert@Home | Application uses missing CUDA GPU
25.12.2012 11:04:19 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 11:04:19 | Albert@Home | Application uses missing ATI GPU
25.12.2012 11:04:19 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 11:04:19 | Donate@Home | Application uses missing ATI GPU
25.12.2012 11:04:19 | Donate@Home | Application uses missing CUDA GPU
25.12.2012 11:04:19 | Einstein@Home | Application uses missing CUDA GPU
25.12.2012 11:04:19 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 11:04:19 | Einstein@Home | Application uses missing ATI GPU
25.12.2012 11:04:19 | | App version needs OpenCL but GPU doesn't support it
25.12.2012 11:04:19 | Milkyway@Home | Application uses missing ATI GPU
25.12.2012 11:04:19 | Milkyway@Home | Application uses missing CUDA GPU
25.12.2012 11:04:19 | GPUGRID | Application uses missing CUDA GPU
25.12.2012 11:04:19 | | Config: use all coprocessors
25.12.2012 11:04:19 | Albert@Home | URL http://albert.phys.uwm.edu/; Computer ID 1894; resource share 20
25.12.2012 11:04:19 | Collatz Conjecture | URL http://boinc.thesonntags.com/collatz/; Computer ID 91024; resource share 0
25.12.2012 11:04:19 | DNA@Home | URL http://dnahome.cs.rpi.edu/dna/; Computer ID 7037; resource share 250
25.12.2012 11:04:19 | Donate@Home | URL http://donateathome.org/; Computer ID 72; resource share 30
25.12.2012 11:04:19 | Einstein@Home | URL http://einstein.phys.uwm.edu/; Computer ID 4600233; resource share 60
25.12.2012 11:04:19 | Test4Theory@Home | URL http://lhcathome2.cern.ch/test4theory/; Computer ID 14436; resource share 350
25.12.2012 11:04:19 | LHC@home 1.0 | URL http://lhcathomeclassic.cern.ch/sixtrack/; Computer ID 9955403; resource share 140
25.12.2012 11:04:19 | Milkyway@Home | URL http://milkyway.cs.rpi.edu/milkyway/; Computer ID 398327; resource share 40
25.12.2012 11:04:19 | orbit@home | URL http://orbit.psi.edu/oah/; Computer ID 84983; resource share 250
25.12.2012 11:04:19 | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 6392383; resource share 10
25.12.2012 11:04:19 | Spinhenge@home | URL http://spin.fh-bielefeld.de/; Computer ID 222736; resource share 250
25.12.2012 11:04:19 | WUProp@Home | URL http://wuprop.boinc-af.org/; Computer ID 29701; resource share 100
25.12.2012 11:04:19 | GPUGRID | URL http://www.gpugrid.net/; Computer ID 121397; resource share 50
25.12.2012 11:04:19 | Collatz Conjecture | General prefs: from Collatz Conjecture (last modified 30-Dec-2009 12:38:08)
25.12.2012 11:04:19 | Collatz Conjecture | Host location: none
25.12.2012 11:04:19 | Collatz Conjecture | General prefs: using your defaults
25.12.2012 11:04:19 | | Reading preferences override file
25.12.2012 11:04:19 | | Preferences:
25.12.2012 11:04:19 | | max memory usage when active: 4606.34MB
25.12.2012 11:04:19 | | max memory usage when idle: 6909.50MB
25.12.2012 11:04:19 | | max disk usage: 18.44GB
25.12.2012 11:04:19 | | (to change preferences, visit the web site of an attached project, or select Preferences in the Manager)
25.12.2012 11:04:19 | | Not using a proxy
25.12.2012 11:04:19 | WUProp@Home | Restarting task wu_v3_1355046001_614316_0 using data_collect_v3 version 336 (nci) in slot 0

edit:
when I first started win8, the gpu's where not found at all.
I downloaded the latest Catalyst-Driver (12.11 Beta 11) and installed it. Looks like that one does not contain open-CL?

I now try to install the latest non-beta and upgrade it afterwards again. I'll keep you informed.

Alexander

Alex
Alex
Joined: 1 Mar 05
Posts: 449
Credit: 368,513,056
RAC: 215,743

No, did not help. Release

No, did not help.
Release notes to the latest official driver say that open-CL is included.
I downloaded latest BM (7.0.42) - did not help.

A look into the directory c:\AMD\AMD_Catalyst_12.11_Beta11\Packages\Apps\OpenCL64 contains a OpenCL.msi.
Trying to start this installer results in the message 'Another Version of this program is already installed'. It says it can be modified or deinstalled via 'Programs' in the control panel. But that does not contain anything like 'Open CL'.

Alexander

Jord
Joined: 26 Jan 05
Posts: 2,952
Credit: 5,734,350
RAC: 241

C:\Windows\system32\ contains

C:\Windows\system32\ contains an OpenCL.dll?
If so, check its Properties->Details. Which file version does it have?

Alex
Alex
Joined: 1 Mar 05
Posts: 449
Credit: 368,513,056
RAC: 215,743

RE: C:\Windows\system32\

Quote:
C:\Windows\system32\ contains an OpenCL.dll?
If so, check its Properties->Details. Which file version does it have?

No, in the complete c:\windows\ only the \DriverStore\FileRepository contains some of these files, all of them beginning with nv_disp.inf ..

Looks like the AMD driver installer is lying when posting 'Installation complete'.

Alexander

Jord
Joined: 26 Jan 05
Posts: 2,952
Credit: 5,734,350
RAC: 241

I take it you used the

I take it you used the drivers from here?
Did you uninstall the drivers that Windows installed, or did you just throw these drivers over the Windows installed ones?

What if you uninstall the drivers, then use something like Driver Sweeper or its successor Driver-Fusion to get rid of the remnants, and only then (after several reboots) install the drivers downloaded from AMD?

I bet you'll have OpenCL capability then.

Edit: The nv* files can be part of motherboard chipset drivers, don't remove them unless you're absolutely sure your motherboard doesn't use anything Nvidia.

Alex
Alex
Joined: 1 Mar 05
Posts: 449
Credit: 368,513,056
RAC: 215,743

Hi Jord, a registry

Hi Jord,

a registry cleanup did the job. After uninstalling all AMD software I hat >120 wrong entries in the registry.

A clean installation afterwards .. and back crunching with the two GPU's.

Thank you !

Alexander

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.