Why do I not get any GPU tasks

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0
Topic 196321

I have 7.0.26 on my Windows host and don't get any more GPU work?

Shall I downgrade again?

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,034
Credit: 220,660,092
RAC: 41,489

Why do I not get any GPU tasks

Did you use anonymous platform before? It looks like some tasks have been assigned on your host to app versions that are no longer supported on the project.

Try resetting the project on the Client.

BM

BM

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0

No, I did not use anonymous

No, I did not use anonymous platform before.

I will reset the project after the current WU is finished.

[edit]I should add that I receive tasks from Albert@home for my GPU. But I have already stopped work from Albert@home for the moment.

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 475,726,621
RAC: 137,106

The problem seems to be the

The problem seems to be the NVIDIA driver version, it's one of those that caused massive computation errors because of a driver bug. Therefore it was decided to exclude hosts with these drivers from getting work at E@H.

The solution would be to downgrade or update the driver, see this thread:
http://einsteinathome.org/node/196188

Cheers
HB

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0

That's a drama, I thought I

That's a drama, I thought I use driver version 295.73?

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 475,726,621
RAC: 137,106

RE: That's a drama, I

Quote:
That's a drama, I thought I use driver version 295.73?

And the first driver version above that that will get you work at E@H is 301.00 .

Cheers
HB

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0

I downgraded to driver

I downgraded to driver 295.73, made a reboot after shutting down all my VirtualBox hosts, reset the project and I still get only tasks for Gamma-ray pulsar search #1 0.34!

Here are the relevant logs:

11.05.2012 09:40:44 | | Local time is UTC +2 hours
11.05.2012 09:40:44 | | VirtualBox version: 4.1.10
11.05.2012 09:40:44 | | NVIDIA GPU 0: GeForce GTX 570 (driver version 295.73, CUDA version 4.20, compute capability 2.0, 1280MB, 1148MB available, 1498 GFLOPS peak)
11.05.2012 09:40:44 | | OpenCL: NVIDIA GPU 0: GeForce GTX 570 (driver version 295.73, device version OpenCL 1.1 CUDA, 1280MB, 1148MB available)

Farther down:

11.05.2012 09:56:47 | Einstein@Home | Requesting new tasks for NVIDIA
11.05.2012 09:56:49 | Einstein@Home | Scheduler request completed: got 0 new tasks
11.05.2012 09:56:49 | Einstein@Home | No work sent

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 475,726,621
RAC: 137,106

Hi! That driver is still

Hi!

That driver is still in the forbidden version range.

You will need to downgrade to 290.53 or below or upgrade to 301.00 or above.

Cheers
HBE

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0

This the driver that was

This the driver that was installed prior.

[edit] They are exactly of the same size!

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,034
Credit: 220,660,092
RAC: 41,489

According to our scheduler

According to our scheduler logs:

Until 2012-05-11 06:55:39 your client reported driver version supplied: 296.10
From 2012-05-11 07:41:02 on your client reported driver version supplied: 295.73

Neither of these will get you CUDA tasks on Einstein@Home. Downgrade to 290.53 or upgrade to 301.xx.

BM

BM

M. Schmitt
M. Schmitt
Joined: 27 Jun 05
Posts: 478
Credit: 15,872,262
RAC: 0

Ok, I installed 280.26 and

Ok, I installed 280.26 and still get no GPU work. I give up and use Linux instead. I installed driver version 296.10 and the same things happen:

This the scheduler log:

2012-05-11 12:08:52.6401 [PID=2259] Request: [USER#xxxxx] [HOST#3960976] [IP xxx.xxx.xxx.27] client 7.0.26
2012-05-11 12:08:52.6558 [PID=2259 ] [handle] [HOST#3960976] [RESULT#287831424] [WU#122947568] got result (DB: server_state=4 outcome=0 client_state=0 validate_state=0 delete_state=0)
2012-05-11 12:08:52.6558 [PID=2259 ] [handle] cpu time 15025.490000 credit/sec 0.010291, claimed credit 154.634243
2012-05-11 12:08:52.6560 [PID=2259 ] [handle] [RESULT#287831424] [WU#122947568]: setting outcome SUCCESS
2012-05-11 12:08:52.6631 [PID=2259 ] [send] effective_ncpus 4 max_jobs_on_host_cpu 999999 max_jobs_on_host 999999
2012-05-11 12:08:52.6631 [PID=2259 ] [send] effective_ngpus 1 max_jobs_on_host_gpu 999999
2012-05-11 12:08:52.6631 [PID=2259 ] [send] Not using matchmaker scheduling; Not using EDF sim
2012-05-11 12:08:52.6631 [PID=2259 ] [send] CPU: req 0.00 sec, 0.00 instances; est delay 0.00
2012-05-11 12:08:52.6632 [PID=2259 ] [send] CUDA: req 0.00 sec, 0.00 instances; est delay 0.00
2012-05-11 12:08:52.6632 [PID=2259 ] [send] work_req_seconds: 0.00 secs
2012-05-11 12:08:52.6632 [PID=2259 ] [send] available disk 46.85 GB, work_buf_min 8640
2012-05-11 12:08:52.6632 [PID=2259 ] [send] active_frac 0.999491 on_frac 0.178166 DCF 1.006248
2012-05-11 12:08:52.6660 [PID=2259 ] [version] Checking plan class 'BRP4cuda32nv301'
2012-05-11 12:08:52.6663 [PID=2259 ] [version] reading plan classes from file '../plan_class_spec.xml'
2012-05-11 12:08:52.6663 [PID=2259 ] [version] parsed project prefs setting 'gpu_util_brp' : false : 0.000000
2012-05-11 12:08:52.6663 [PID=2259 ] [version] driver version required min: -30100, supplied: 29573
2012-05-11 12:08:52.6663 [PID=2259 ] [version] Checking plan class 'BRP4SSE'
2012-05-11 12:08:52.6664 [PID=2259 ] [version] parsed project prefs setting 'also_run_cpu' : true : 1.000000
2012-05-11 12:08:52.6664 [PID=2259 ] [version] project prefs setting 'also_run_cpu' (1.000000) prevents using plan class.
2012-05-11 12:08:52.6664 [PID=2259 ] [version] Checking plan class 'BRP4cuda32'
2012-05-11 12:08:52.6664 [PID=2259 ] [version] parsed project prefs setting 'gpu_util_brp' : false : 0.000000
2012-05-11 12:08:52.6664 [PID=2259 ] [version] driver version required max: -29053, supplied: 29573
2012-05-11 12:08:52.6664 [PID=2259 ] [version] no app version available: APP#19 (einsteinbinary_BRP4) PLATFORM#2 (windows_intelx86) min_version 0
2012-05-11 12:08:52.6664 [PID=2259 ] [CRITICAL] [HOST#3960976] can't resend [RESULT#286909462]: no app version for einsteinbinary_BRP4
2012-05-11 12:08:52.6670 [PID=2259 ] [CRITICAL] [HOST#3960976] can't resend [RESULT#286909651]: no app version for einsteinbinary_BRP4
2012-05-11 12:08:52.6676 [PID=2259 ] [CRITICAL] [HOST#3960976] can't resend [RESULT#286926999]: no app version for einsteinbinary_BRP4
2012-05-11 12:08:52.6684 [PID=2259 ] [CRITICAL] [HOST#3960976] can't resend [RESULT#286927019]: no app version for einsteinbinary_BRP4
2012-05-11 12:08:52.6693 [PID=2259 ] Sending reply to [HOST#3960976]: 0 results, delay req 60.00
2012-05-11 12:08:52.6696 [PID=2259 ] Scheduler ran 0.036 seconds

I have reset the project several times, quit work and now this: no app version einstein BRP4

Messages:

11.05.2012 14:24:13 | Einstein@Home | Requesting new tasks for NVIDIA
11.05.2012 14:24:16 | Einstein@Home | Scheduler request completed: got 0 new tasks
11.05.2012 14:24:16 | Einstein@Home | No work sent
11.05.2012 14:24:16 | Einstein@Home | see scheduler log messages on http://einstein.phys.uwm.edu//host_sched_logs/3960/3960976
11.05.2012 14:24:33 | Einstein@Home | Finished download of einstein_S6LV1_1.13_windows_intelx86__SSE2.exe
11.05.2012 14:24:35 | Einstein@Home | Starting task h1_0259.05_S6GC1__696_S6LV1B_0 using einstein_S6LV1 version 113 (SSE2) in slot 2

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.