Trouble with Gamma-ray pulsar search #2 v0.01

Justin La Sotten
Justin La Sotten
Joined: 9 Dec 05
Posts: 6
Credit: 2,930,440
RAC: 0
Topic 196705

Each and every unit I get for Gamma-ray pulsar search #2 v0.01 fails with an error.

Here is an example unit: http://einsteinathome.org/task/329383144

Can anyone tell what is wrong? Or why it failed? From what I can see (and understand) is that it can't find a checkpoint file.
All the other unit types are working just fine.

Machine is 64-bit linux with 32-bit compat libs isntalled.

Output of 'ldd hsgamma_FGRP2_0.01_i686-pc-linux-gnu':

linux-gate.so.1 =>  (0xf776b000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf772e000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7702000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7557000)
/lib/ld-linux.so.2 (0xf776c000)

Thank for any help in advance, I'd love to crunch these units

Justin La Sotten
Justin La Sotten
Joined: 9 Dec 05
Posts: 6
Credit: 2,930,440
RAC: 0

Trouble with Gamma-ray pulsar search #2 v0.01

I also did a project reset to see if that fixes it. But I seem to be getting a lot of:

"Task LAT##### exited with a zero status but no 'finished' file"

What I also find odd is that in my project preferences, i've temporarily disabled Gamma-ray pular search, yet I keep getting new units for it.

Khangollo
Khangollo
Joined: 17 Feb 11
Posts: 42
Credit: 919,956,402
RAC: 34,642

I had the exact same problem

I had the exact same problem with GRPS 0.01 and BOINC 7.0.42. It appears to be BOINC 7.X + Linux + newer Einstein app. builds related.
00:41:33 (453): No heartbeat from client for 30 sec - exiting
Project application will actually crunch then exit with this message, continually, until stderr log size limit is exceeded and task fails.
I noticed similar problem already with BRP v1.31 CUDA application (but boinc 7.x + BRP 1.28 worked OK on the same machine!) - sometimes it will just exit, crying there was no heartbeat from boinc.
I solved the problem for good by downgrading BOINC 7.x back to 6.12.43. Works 100% reliable now.

MaU38.gif

Jeroen
Jeroen
Joined: 25 Nov 05
Posts: 379
Credit: 738,423,020
RAC: 0

The issue with the hsgamma

The issue with the hsgamma application restarting and eventually failing happens with BOINC 7.0.42 and newer. If you downgrade to BOINC 7.0.36, your Gamma Ray tasks should run successfully in Linux.

Neil Newell
Neil Newell
Joined: 20 Nov 12
Posts: 176
Credit: 169,699,457
RAC: 0

I had the same too (using

I had the same too (using BOINC 7.1.0); every unit failed, across multiple systems, exiting after a few seconds. As others have reported, the fix was to switch to 7.0.28.

archae86
archae86
Joined: 6 Dec 05
Posts: 2,825
Credit: 3,303,584,359
RAC: 2,564,619

Neil Newell wrote:the fix was

Neil Newell wrote:
the fix was to switch to 7.0.28.

I also am running 7.0.28 on all my hosts, but I have never run something higher.

Claggy
Claggy
Joined: 29 Dec 06
Posts: 560
Credit: 2,554,778
RAC: 214

RE: I had the same too

Quote:
I had the same too (using BOINC 7.1.0); every unit failed, across multiple systems, exiting after a few seconds. As others have reported, the fix was to switch to 7.0.28.


There hasn't been an Official Boinc 7.1.x build yet, the only way i know of how you could be running a Boinc 7.1.0 client is if you got hold of a diagnostic buld from Rom or Dave,
(i ran a Diagnostic version of one of the 7.0.3x builds only a few weeks ago that called itself 7.1.0),

So really you're running an Unknown Diagnostic Build of one of the 7.0.x clients that doesn't work, anywhere from an early 7.0.0x client right up to the latest 7.0.42 client.

Claggy

Jord
Joined: 26 Jan 05
Posts: 2,952
Credit: 5,685,975
RAC: 435

RE: ...the only way i know

Quote:
...the only way i know of how you could be running a Boinc 7.1.0 client is if you got hold of a diagnostic buld from Rom or Dave


When you build BOINC from source, but do not adjust the version number in the version.h file, the version number becomes 7.1.0

From http://boinc.berkeley.edu/trac/browser/boinc/version.h:

/* Platform independent version definitions... */

#ifndef BOINC_VERSION_H
#define BOINC_VERSION_H

/* Major part of BOINC version number */
#define BOINC_MAJOR_VERSION 7

/* Minor part of BOINC version number */
#define BOINC_MINOR_VERSION 1

/* Release part of BOINC version number */
#define BOINC_RELEASE 0

/* String representation of BOINC version number */
#define BOINC_VERSION_STRING "7.1.0"

/* Package is a pre-release (Alpha/Beta) package */
#define BOINC_PRERELEASE 1

#if (defined(_WIN32) || defined(__APPLE__))
/* Name of package */
#define PACKAGE "boinc"

/* Define to the address where bug reports for this package should be sent. */
#define PACKAGE_BUGREPORT ""

/* Define to the full name of this package. */
#define PACKAGE_NAME "BOINC"

/* Define to the full name and version of this package. */
#define PACKAGE_STRING "BOINC 7.1.0"

/* Define to the one symbol short name of this package. */
#define PACKAGE_TARNAME "boinc"

/* Define to the version of this package. */
#define PACKAGE_VERSION "7.1.0"

#endif /* #if (defined(_WIN32) || defined(__APPLE__)) */

#endif /* #ifndef BOINC_VERSION_H */

Claggy
Claggy
Joined: 29 Dec 06
Posts: 560
Credit: 2,554,778
RAC: 214

Thanks, so he's built Boinc

Thanks, so he's built Boinc from source at some point, and it could have been at any time, and could be almost any Boinc 7.0.x sub version ;-)

Claggy

Neil Newell
Neil Newell
Joined: 20 Nov 12
Posts: 176
Credit: 169,699,457
RAC: 0

Indeed, you've called it

Indeed, you've called it exactly- I built it from source (20th November) since the pre-built packages didn't work for me. So I just followed the instructions on the "Application Source Code and License" link on the front page.

It was only later I realised this gives the latest version, but since the work across 15 hosts was validating ok (bar a few GPU errors) I left it. But then the FGRP2 app didn't work, so I checked out the source for 7.0.28 and built that, which fixed the problem. I didn't have to abort any work or reset the project - the logjam of failing FGRP2 tasks then went through and are all now almost entirely validated (no errors, a few still pending).

I've still got both versions installed if this will help anyone looking for the underlying cause of the problem.

Claggy
Claggy
Joined: 29 Dec 06
Posts: 560
Credit: 2,554,778
RAC: 214

RE: I've still got both

Quote:
I've still got both versions installed if this will help anyone looking for the underlying cause of the problem.


No point, you built it between tagged releases of Boinc 7.0.36 and 7.0.37, a halfway house, possibly fixed in a later changeset, try building Boinc 7.0.42 and see if the problem still exists,

Claggy

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.