Report Web site Problems Here

Shawn Kwang
Shawn Kwang
Joined: 3 Nov 15
Posts: 289
Credit: 2,246,986
RAC: 1,097
Topic 199241

Please report and problems with the Einstein@Home Web site in this thread. With the new Drupal CMS layout and design, we created a new thread for users to post issues. However, feel free to post new threads/issues in the forum as well.

Einstein@Home Project

Rantanplan
Rantanplan
Joined: 13 Dec 08
Posts: 87
Credit: 50,383,365
RAC: 0

ok, i am first. At this point

well, i found it, thx

 

Shawn Kwang
Shawn Kwang
Joined: 3 Nov 15
Posts: 289
Credit: 2,246,986
RAC: 1,097

Rantanplan wrote:well, i

Rantanplan wrote:

well, i found it, thx

 

No problem. In general we're all going to take some time to figuring out the new design and where everything is located.

Einstein@Home Project

Juha
Juha
Joined: 27 Nov 14
Posts: 49
Credit: 4,946,371
RAC: 41

News is missing from forum

News is missing from forum index. I rarely visit the main page; I always have a tab open in the forum index page so it would be nice if News were there too.

Forum layout doesn't adjust to small screen/window size. Right now I have to scroll horizontally to read threads. edit: It's pretty much the entire site that doesn't adjust to small screen.

Font in forum posts is awfully small. The new comment text box actually has larger font than the forum posts.

Featured threads don't show time of last post.

home.php and hosts_user.php are missing redirects.

When rich-text is enabled the Post new comment text box has text "Path: p" under it. What's that? edit: Oh, HTML path.

When collapsed, the text "INPUT FORMAT" has a few rows of pixels missing from it.

edit: some more:

The Write new [private] message page apparently shows and expects a Drupal user account. For example, I'm Juha_6 and Gavin from this post is Gavin_14.

Can't post new comments in any news post that doesn't already have comments.

Can't find logout button anywhere.

After removing E@H cookies, the only way to log back in that I could find was the login link in forums. The link doesn't exactly stand out.

I don't know if it should but einstein.phys.uwm.edu/index.php doesn't redirect to einsteinathome.org but forums.php, for example, does.

When not logged in Teams page tells me I need 1 more credit to create a new team.

When not logged in the forum posts have Send [private] message button. Clicking it takes the browser to the front page.

 

Harri Liljeroos
Harri Liljeroos
Joined: 10 Dec 05
Posts: 1,927
Credit: 1,957,696,160
RAC: 2,170,886

I tried to update my avatar

I tried to update my avatar as it was lost and got this error:

An HTTP error 0 occured /filefield/ahah/profile/field_image/0

 

And when I tried to save the changes to my profile the next page shows this:

{ "status": true, "data": "\x3cdiv class=\"form-item\" id=\"edit-field-image-0-upload-wrapper\"\x3e\n \x3clabel for=\"edit-field-image-0-upload\"\x3eUpload an avatar: \x3c/label\x3e\n \x3cdiv class=\"filefield-element clear-block\"\x3e\x3cdiv class=\"widget-preview\"\x3e\x3cdiv class=\"imagefield-preview\"\x3e\x3cimg src=\"https://einsteinathome.org/sites/default/files/imagefield_thumbs/profiles/135862_avatar_3.jpg?1470419682\" title=\"135862_avatar.jpg\" alt=\"Image preview\" /\x3e\x3c/div\x3e\x3c/div\x3e\x3cdiv class=\"widget-edit\"\x3e\x3cinput type=\"hidden\" name=\"field_image[0][UPLOAD_IDENTIFIER]\" id=\"edit-field-image-0-UPLOAD-IDENTIFIER\" value=\"f0be61aab0b7a8cf295567f499dc1862\" class=\"filefield-progress\" /\x3e\n\x3cinput type=\"hidden\" name=\"field_image[0][fid]\" id=\"edit-field-image-0-fid\" value=\"10699\" /\x3e\n\x3cinput type=\"hidden\" name=\"field_image[0]

" id="edit-field-image-0-list" value="1" /\x3e\n\x3cinput type="submit" name="field_image_0_filefield_remove" id="edit-field-image-0-filefield-remove" value="Remove" class="form-submit" /\x3e\n\x3c/div\x3e\x3c/div\x3e\n\x3c/div\x3e\n\x3cscript type="text/javascript"\x3ejQuery.extend(Drupal.settings.ahah, { "edit-field-image-0-filefield-upload": { "url": "/filefield/ahah/profile/field_image/0", "event": "mousedown", "keypress": true, "wrapper": "edit-field-image-0-ahah-wrapper", "selector": "#edit-field-image-0-filefield-upload", "effect": "fade", "method": "replace", "progress": { "type": "bar", "path": "filefield/progress/f0be61aab0b7a8cf295567f499dc1862", "url": "/filefield/progress/f0be61aab0b7a8cf295567f499dc1862" }, "button": { "op": "Upload" } }, "edit-field-image-0-filefield-remove": { "url": "/filefield/ahah/profile/field_image/0", "event": "mousedown", "keypress": true, "wrapper": "edit-field-image-0-ahah-wrapper", "selector": "#edit-field-image-0-filefield-remove", "effect": "fade", "method": "replace", "progress": { "type": "throbber" }, "button": { "field_image_0_filefield_remove": "Remove" } } });\x3c/script\x3e" }

It would be good to have link to the forum at the bottom of the page like there is at the top of the page like:

FORUMS > PROBLEMS AND BUG REPORTS

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 903
Credit: 25,165,933
RAC: 0

The upload issue is already

The image upload issue is already known. We're looking into it.

 

Einstein@Home Project

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 903
Credit: 25,165,933
RAC: 0

Juha wrote:Forum layout

Juha wrote:

Forum layout doesn't adjust to small screen/window size. Right now I have to scroll horizontally to read threads. edit: It's pretty much the entire site that doesn't adjust to small screen.

Valid point. Should be improved.

Quote:

Font in forum posts is awfully small. The new comment text box actually has larger font than the forum posts.

Can't reproduce it. It should help to constrain the minimum font size in your browser which is generally a good idea.

Quote:

home.php and hosts_user.php are missing redirects.

Where are they referenced other than on the (old) apps page?

Quote:

The Write new [private] message page apparently shows and expects a Drupal user account. For example, I'm Juha_6 and Gavin from this post is Gavin_14.

Agreed, needs improving

Quote:

Can't post new comments in any news post that doesn't already have comments.

You can post as long it isn't a read-only news item.

Quote:

Can't find logout button anywhere.

After removing E@H cookies, the only way to log back in that I could find was the login link in forums. The link doesn't exactly stand out.

Erm, have a look at the main menu (for either case).

Quote:

I don't know if it should but einstein.phys.uwm.edu/index.php doesn't redirect to einsteinathome.org but forums.php, for example, does.

Yep, would be more consistent.

Quote:

When not logged in Teams page tells me I need 1 more credit to create a new team.

Not exactly wrong Wink But yes, being not logged in is the deciding factor here.

Quote:

When not logged in the forum posts have Send [private] message button. Clicking it takes the browser to the front page.

Clearly unwanted behavior.

 

Thanks for your feedback!

 

Einstein@Home Project

AgentB
AgentB
Joined: 17 Mar 12
Posts: 915
Credit: 513,211,304
RAC: 0

Well done on getting this up

Well done on getting this up and running on schedule.

Community Preferences pages missing (or i can't find) a number of functions and settings

Especially the

  • filtered users (Ignore message board posts and private messages from these users)
  • number of posts per page [now found]

I don't see the need to capitalize names.


Edit: edit works!

Edit++: Strangely I could return to edit this post after i posted a new one.

AgentB
AgentB
Joined: 17 Mar 12
Posts: 915
Credit: 513,211,304
RAC: 0

Edit works but not for very

Edit works but not for very long.

Found: number of posts per page

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 903
Credit: 25,165,933
RAC: 0

Posts per page can be set

  • Posts per page can be set here
  • You can ban someone but I'm not sure it will also filter all message board posts

Cheers

 

Einstein@Home Project

AgentB
AgentB
Joined: 17 Mar 12
Posts: 915
Credit: 513,211,304
RAC: 0

Oliver Bock wrote:You can

Oliver Bock wrote:
  • You can ban someone but I'm not sure it will also filter all message board posts

Thanks Oliver, just found it - you can click on the IGNORE link to add. If you have a list and a user in the thread is on the list this link

ignore list

appears.  It would be helpful to have that link in the Community Preference page.  ... and better still the list has been migrated which was a pleasant surprise.  I can live with that, i might go so far to say - i'm starting to like it WITH ONE SMALL CAVEAT ...

 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.