Raise of minimum required BOINC Core Client version

ForumsTechnical News

Bernd Machenschalk
Bernd Machenschalk
Joined: 15 Oct 04
Posts: 3620
Credit: 130117366
RAC: 60878
Topic 195456

This is an early pre-warning: At some point in the next weeks or months, but definitely before the end of the upcoming GW run S5GC1HF we will raise the minimum BOINC Core Client version required for Einstein@home from 4.19 to 5.8.0. People using older Core Clients will need to upgrade to get work then.

BM

BM

mikey
mikey
Joined: 22 Jan 05
Posts: 2608
Credit: 166200330
RAC: 168026

Raise of minimum required BOINC Core Client version

Quote:

This is an early pre-warning: At some point in the next weeks or months, but definitely before the end of the upcoming GW run S5GC1HF we will raise the minimum BOINC Core Client version required for Einstein@home from 4.19 to 5.8.0. People using older Core Clients will need to upgrade to get work then.

BM

You might want to put this on the front page and email it to all those using older versions. I know SOME people feel they cannot upgrade due to using their pc's at work, so you might lose some folks over this. Others will take the chance to do better Science! I would guess though that alot of us are already past that point. Good luck and I hope for the best!!

Bernd Machenschalk
Bernd Machenschalk
Joined: 15 Oct 04
Posts: 3620
Credit: 130117366
RAC: 60878

RE: You might want to put

Quote:
You might want to put this on the front page and email it to all those using older versions.

I intended to do this when I have a bit clearer idea of the time we actually will do that.

Quote:
I know SOME people feel they cannot upgrade due to using their pc's at work, so you might lose some folks over this.

Well, you should run BOINC "only on computers that you own, or for which you have obtained the owner's permission." What I'm more worried about are the people that run the stock client of their Linux distributions, some of which are pretty conservative. This includes some LSC computing clusters, btw.

Quote:
Others will take the chance to do better Science!

The main feature that we need is the feature to compress the result file before it's sent back to the server. Currently the <10% of result files that are not compressed are taking up more than half of the storage space, I/O bandwith etc. on the server side. (We once used to compress the result files in the application, but BOINC dropped support for the boinc_zip library long ago and for good reason).

BM

BM

.clair.
.clair.
Joined: 20 Nov 06
Posts: 50
Credit: 11162161
RAC: 0

And here was me thinking that

And here was me thinking that my pair of win98se crunchers running 5.10.45 was an `old` version :)
The rest are on 6+.

mikey
mikey
Joined: 22 Jan 05
Posts: 2608
Credit: 166200330
RAC: 168026

RE: RE: You might want to

Quote:
Quote:
You might want to put this on the front page and email it to all those using older versions.

I intended to do this when I have a bit clearer idea of the time we actually will do that.

I saw you did it, it looks nice!

Quote:
Quote:
I know SOME people feel they cannot upgrade due to using their pc's at work, so you might lose some folks over this.

Well, you should run BOINC "only on computers that you own, or for which you have obtained the owner's permission." What I'm more worried about are the people that run the stock client of their Linux distributions, some of which are pretty conservative. This includes some LSC computing clusters, btw.

It totally agree but you know people!

Quote:
Quote:
Others will take the chance to do better Science!

The main feature that we need is the feature to compress the result file before it's sent back to the server. Currently the <10% of result files that are not compressed are taking up more than half of the storage space, I/O bandwith etc. on the server side. (We once used to compress the result files in the application, but BOINC dropped support for the boinc_zip library long ago and for good reason).
BM

Hmmm you learn something every day, I now know what I learned today!! Thanks!!

But why stop at version 5.8? Why not make people go all the way to 6.x instead? As stated by clive alot of us are already into the 6.x versions anyway. Versions 6.10.58 is the recommended version now and 6.12.6 is the latest development version available. I think 6.4.5 is the minimum to be able to use a gpu while crunching. And you are working on a new version of that software.

Bernd Machenschalk
Bernd Machenschalk
Joined: 15 Oct 04
Posts: 3620
Credit: 130117366
RAC: 60878

RE: But why stop at version

Quote:
But why stop at version 5.8?

For all people manually upgrading their machines I strongly recommend to use one of the newest available Clients. However we do have some major contributors that still stick to a 5.8 client, and apparently upgrading is not easy for them.

BM

BM

Gundolf Jahn
Gundolf Jahn
Joined: 1 Mar 05
Posts: 1079
Credit: 341280
RAC: 0

RE: But why stop at version

Quote:
But why stop at version 5.8?


BOINC 5.8.16 is the last version compatible with windows NT4!

Gruß,
Gundolf

Computer sind nicht alles im Leben. (Kleiner Scherz)

Odysseus
Odysseus
Joined: 17 Dec 05
Posts: 372
Credit: 5975656
RAC: 4507

I have been unsuccessful

I have been unsuccessful getting BOINC v6.x to run on my older Macs as well. Not all of them are yet at v5.8 or higher, but I expect upgrades to that level will be feasible.

Richard Haselgrove
Richard Haselgrove
Joined: 10 Dec 05
Posts: 1721
Credit: 66813704
RAC: 55413

I've noticed a small problem

I've noticed a small problem with this when setting up host 3674581 for a burn-in test.

It's modern server hardware, so should perform well on Einstein tasks. But it's running Windows Small Business Server 2008 - which means it is running (has to run) as a Domain Controller. That in turn means that I'm restricted to BOINC v5.10.xx maximum. And that in turn means that all that lovely hardware is running base-level stock code, with no SIMD optimisations. Seems a shame, really.

mikey
mikey
Joined: 22 Jan 05
Posts: 2608
Credit: 166200330
RAC: 168026

RE: RE: But why stop at

Quote:
Quote:
But why stop at version 5.8?

BOINC 5.8.16 is the last version compatible with windows NT4!

Gruß,
Gundolf

WOW sooo many things to consider that I never had! Thanks for the info guys!

Brian Priebe
Brian Priebe
Joined: 28 Nov 09
Posts: 2
Credit: 25545497
RAC: 62

RE: But it's running

Quote:
But it's running Windows Small Business Server 2008 - which means it is running (has to run) as a Domain Controller. That in turn means that I'm restricted to BOINC v5.10.xx maximum.


Check out this thread over at Collatz: http://boinc.thesonntags.com/collatz/forum_thread.php?id=455&nowrap=true#7137. Thanks to Crunch3r's method, I'm running 6.10.56 on a Windows 2003 Server domain controller under the Administrator account.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.