Never thought I could get credit for this WU

Sharky T
Sharky T
Joined: 19 Feb 05
Posts: 159
Credit: 1,173,301
RAC: 0
Topic 189164

Here's the story:
In an attempt to stop several harddrives constantly whining, I copied the boinc-folders from each machine
to only one drive.And named them differently to keep them apart.And then made those folders shared.
Then I tried to start boinc on each computer via LAN,and they all started fine.
Well,when coming home from work I saw a lot of
error messages in boinc "Can't get application drive usage: -111" or something.
No,it didn't look good and had no desire to solve it,so I stoped everything and copied back the LAN-boinc-folders to each comp again.
When starting it all again it showed some trashed WU and the rest had 3-4 times longer crunchingtimes than usual. To my eyes this didn't look right,so I canceled two WU and let one looong WU do its job to
see what happends.
That particular WU actually gave me credit!!
Well,it tried to claim 214 for it, but of course the hi and lo are allways erased in the credit-calculation. I am just so surprised that this WU got through the validation. Has this WU been calculated several times because of the diskusage-problem?

The unit can be seen here


gravywavy
gravywavy
Joined: 22 Jan 05
Posts: 392
Credit: 68,962
RAC: 0

Never thought I could get credit for this WU

hi Sharky,

when the client starts up and finds a part processed wu, if it suspects that the results file is corrupt it restarts that wu from the beginning. On v4.19 it would sometimes keep the clock going on the time elapsed, so if the wu had already run for 9hrs when it restarted, even tho it restarted the comp the client would show 9hrs already done with 100% still to do. Don't know if this is the explanation here, or something else, but after that experience with v4.19 your experience does not surprise me.

~~gravywavy

Sharky T
Sharky T
Joined: 19 Feb 05
Posts: 159
Credit: 1,173,301
RAC: 0

I buy that explanation. :) I

Message 11587 in response to message 11586

I buy that explanation. :)
I guess it must have been like that. Started from scratch several times and not reseting the crunchtime.
My core client was dev.version 4.38 at that time.(I like it better than 4.25)


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.