Lots of errors (gpu crunching, error 1024)

mohavewolfpup
mohavewolfpup
Joined: 8 Mar 20
Posts: 5
Credit: 2,370,684
RAC: 24,563
Topic 222988

So I went to bed and there was a few errors (mainly from not finishing units in time, my bad) and then when I woke up, checked to see if any other issues happened.

Now it's up to 17 errors and probably more might be coming, so I have this system offline until it's figured out.

Host System

Lots of error 1024, not sure what this fully is. Did have a nvidia driver update, so I did that but haven't restarted. Is this normal, or is the system polluting results?

Did Find This which my error logs have, but more confused on it. System just runs windows 7 professional, not video gaming or anything. Just lays dormant.

Dell Optiplex 3020, 16 gigs of ram, 1tb hard disk (644 gb free), Intel Core I-5 3.20, 4 cores. Nvidia GeForce GT 730 video card (2 gigs)

A older ATI equipped workstation next to it is slowly chugging along on units, but it's polluting with errors. So not really sure what is up at this point Normal system

Betreger
Betreger
Joined: 25 Feb 05
Posts: 920
Credit: 547,770,823
RAC: 316,974

Your system withe the GT730

Your system withe the GT730 is not suited to run gravity wave GPU tasks. They need at least 4GB of memory. It will run Pulsars on the GPU just fine. 

mohavewolfpup
mohavewolfpup
Joined: 8 Mar 20
Posts: 5
Credit: 2,370,684
RAC: 24,563

Thanks, just ditched that out

Thanks, just ditched that out of the options. Man this is such a resource hog compared to seti@home and more confusing. Hopefully it's adjusted now

Mad_Max
Mad_Max
Joined: 2 Jan 10
Posts: 147
Credit: 1,689,632,932
RAC: 333,704

Since when has this

Since when has this requirement been increased? Previously, it was 2GB and not so long ago (about 2.5 month), the Bernd Machenschalk wrote that there are no plans to increase it in "foreseeable future": https://einsteinathome.org/content/gravitational-wave-search-o2-multi-directional-o2md1?page=10#comment-176722

I guess this can be the cause of slow performance and STRANGE random problems that I have been observing for the last few days on one of the computers (while the 2nd one works without problems) while both have the same video cards(RX 570) use same OS/BOINC/video drivers/etc and both running 2 GW tasks in parallel.
Only one video card has 8 GB of on-board memory, and the other with 4GB.
Radeon RX570 4/8 GB

It can be due to "GPU RAM swapping" (to main system RAM and back) on 4 GB card...

 

P.S.

I guess we are already beyond "foreseeable future" then? :)

Ian&Steve C.
Ian&Steve C.
Joined: 19 Jan 20
Posts: 207
Credit: 396,480,177
RAC: 389,952

Mad_Max wrote: Since when

Mad_Max wrote:

Since when has this requirement been increased? Previously, it was 2GB and not so long ago (about 2.5 month), the Bernd Machenschalk wrote that there are no plans to increase it in "foreseeable future": https://einsteinathome.org/content/gravitational-wave-search-o2-multi-directional-o2md1?page=10#comment-176722

I guess this can be the cause of slow performance and STRANGE random problems that I have been observing for the last few days on one of the computers (while the 2nd one works without problems) while both have the same video cards(RX 570) use same OS/BOINC/video drivers/etc and both running 2 GW tasks in parallel.
Only one video card has 8 GB of on-board memory, and the other with 4GB.
Radeon RX570 4/8 GB

It can be due to "GPU RAM swapping" (to main system RAM and back) on 4 GB card...

 

P.S.

I guess we are already beyond "foreseeable future" then? :)

 

I get the feeling that either Bernd was not aware of the WUs requiring more, or there was some bug causing it to use more when it shouldnt have been. not all of the WUs require >3GB, but when you get hit with them, they cause problems if you have a GPU with insufficient memory. Bernd has commented recently that they are suspending the GW work to investigate the scheduler issue.

_____________________________________________


Mad_Max
Mad_Max
Joined: 2 Jan 10
Posts: 147
Credit: 1,689,632,932
RAC: 333,704

Yeah, i did some monitoring

Yeah, i did some monitoring and saw few WUs which consume about 3100 MB of GPU RAM each.

While majority of WUs fit under <2000 MB.

 

It can easily explain why i saw random problems with running 2 GW WUs in parallel on 4 GB card.

Depending on particular WUs set i got in BOINC work queue (which is pseudo random) it can both fit in 4 GB of memory if it two "small" WUs (and so 2x GW WUs run smoothly), and exceed 4GB of onboard RAM if one or both WUs are "big" ones causing various problems due to out of GPU RAM.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.