How to change the host name of a secondary Boinc client on the same computer?

Mr P Hucker
Mr P Hucker
Joined: 12 Aug 06
Posts: 819
Credit: 481,409,762
RAC: 2,206
Topic 229076

I have two clients running at once on one computer, but they both show up as the same name on my Einstein account.  The server seems to be able to tell which is which, but it's confusing for me.  How do I change one?  For example they're currently Ryzen2 and Ryzen2 (the domain name of the computer on my home network).  I want say Ryzen2 and Ryzen2a.

If this page takes an hour to load, reduce posts per page to 20 in your settings, then the tinpot 486 Einstein uses can handle it.

Harri Liljeroos
Harri Liljeroos
Joined: 10 Dec 05
Posts: 3,676
Credit: 2,922,003,613
RAC: 1,029,962

You should be able to do it

You should be able to do it in cc_config.xml. Check Boinc client configuration from https://boinc.berkeley.edu/wiki/Client_configuration and look for <device_name>NAME</device_name>.

Mr P Hucker
Mr P Hucker
Joined: 12 Aug 06
Posts: 819
Credit: 481,409,762
RAC: 2,206

Doesn't work, I get:74  

Doesn't work, I get:

74            Tue, 14/2/2023 02:55:14 PM    Unrecognized tag in cc_config.xml: <device_name>    
75            Tue, 14/2/2023 02:55:14 PM    Error in cc_config.xml options    
76            Tue, 14/2/2023 02:55:14 PM    Missing end tag in cc_config.xml

Does this happen to anyone else?  Is this a bug in Boinc?

If this page takes an hour to load, reduce posts per page to 20 in your settings, then the tinpot 486 Einstein uses can handle it.

San-Fernando-Valley
San-Fernando-Valley
Joined: 16 Mar 16
Posts: 262
Credit: 7,152,144,928
RAC: 15,773,904

I'll add my garbage.I

I'll add my garbage.

I just tested it and it WORKS !

 

So Peter:

I know you know what you are doing, but I would just like to mention the following.

That command  <device_name>NAME</device_name>

(were NAME is, as you know, per default the domain name)

must be placed, as you know, under  <options> .

Now if that nice dirty BOINC says "missing end tag" ........  hmmm

I know you have checked the syntax more than once ...

... I'm running out of ideas.

Nice day - cheers

S-F-V

 

EDIT:

just tried to delete <device_name> from <options> but didn't work, like when I

added it and selecting "read config files".

I had to restart lovely BOINC ...

Link
Link
Joined: 15 Mar 20
Posts: 97
Credit: 604,605
RAC: 570

If you still can't get it to

If you still can't get it to work, post the entire cc_config.xml here, otherwise it's hard to guess what's wrong.

.

Ian&Steve C.
Ian&Steve C.
Joined: 19 Jan 20
Posts: 3,703
Credit: 34,560,583,430
RAC: 41,763,850

likely an error in cc_config.

likely an error in cc_config. missing a closing end tag/element or something, and <device_name> tag not in the right place. needs to be inside the <options> element as per the documentation. also need to recycle BOINC for changes in cc_config.

_________________________________________________________________________

Mr P Hucker
Mr P Hucker
Joined: 12 Aug 06
Posts: 819
Credit: 481,409,762
RAC: 2,206

I can't see anything wrong,

I can't see anything wrong, this is the file:

 

<cc_config>
    <log_flags>
        <file_xfer>1</file_xfer>
        <sched_ops>1</sched_ops>
        <task>1</task>
        <app_msg_receive>0</app_msg_receive>
        <app_msg_send>0</app_msg_send>
        <async_file_debug>0</async_file_debug>
        <benchmark_debug>0</benchmark_debug>
        <checkpoint_debug>0</checkpoint_debug>
        <coproc_debug>0</coproc_debug>
        <cpu_sched>0</cpu_sched>
        <cpu_sched_debug>0</cpu_sched_debug>
        <cpu_sched_status>0</cpu_sched_status>
        <dcf_debug>0</dcf_debug>
        <disk_usage_debug>0</disk_usage_debug>
        <file_xfer_debug>0</file_xfer_debug>
        <gui_rpc_debug>0</gui_rpc_debug>
        <heartbeat_debug>0</heartbeat_debug>
        <http_debug>0</http_debug>
        <http_xfer_debug>0</http_xfer_debug>
        <idle_detection_debug>0</idle_detection_debug>
        <mem_usage_debug>0</mem_usage_debug>
        <network_status_debug>0</network_status_debug>
        <notice_debug>0</notice_debug>
        <poll_debug>0</poll_debug>
        <priority_debug>0</priority_debug>
        <proxy_debug>0</proxy_debug>
        <rr_simulation>0</rr_simulation>
        <rrsim_detail>0</rrsim_detail>
        <sched_op_debug>0</sched_op_debug>
        <scrsave_debug>0</scrsave_debug>
        <slot_debug>0</slot_debug>
        <state_debug>0</state_debug>
        <statefile_debug>0</statefile_debug>
        <suspend_debug>0</suspend_debug>
        <task_debug>0</task_debug>
        <time_debug>0</time_debug>
        <trickle_debug>0</trickle_debug>
        <unparsed_xml>0</unparsed_xml>
        <work_fetch_debug>0</work_fetch_debug>
    </log_flags>
    <options>
        <abort_jobs_on_exit>0</abort_jobs_on_exit>
        <allow_multiple_clients>1</allow_multiple_clients>
        <allow_remote_gui_rpc>1</allow_remote_gui_rpc>
        <client_version_check_url>https://boinc.berkeley.edu/download.php?xml=1</client_version_check_url>
        <client_new_version_text></client_new_version_text>
        <client_download_url>https://boinc.berkeley.edu/download.php</client_download_url>
        <device_name>test<device_name>
        <disallow_attach>0</disallow_attach>
        <dont_check_file_sizes>0</dont_check_file_sizes>
        <dont_contact_ref_site>0</dont_contact_ref_site>
        <lower_client_priority>0</lower_client_priority>
        <dont_suspend_nci>0</dont_suspend_nci>
        <dont_use_vbox>0</dont_use_vbox>
        <exit_after_finish>0</exit_after_finish>
        <exit_before_start>0</exit_before_start>
        <exit_when_idle>0</exit_when_idle>
        <fetch_minimal_work>0</fetch_minimal_work>
        <fetch_on_update>0</fetch_on_update>
        <force_auth>default</force_auth>
        <http_1_0>0</http_1_0>
        <http_transfer_timeout>300</http_transfer_timeout>
        <http_transfer_timeout_bps>10</http_transfer_timeout_bps>
        <max_event_log_lines>2000</max_event_log_lines>
        <max_file_xfers>8</max_file_xfers>
        <max_file_xfers_per_project>2</max_file_xfers_per_project>
        <max_stderr_file_size>0</max_stderr_file_size>
        <max_stdout_file_size>0</max_stdout_file_size>
        <max_tasks_reported>0</max_tasks_reported>
        <ncpus>-1</ncpus>
        <network_test_url>https://www.google.com/</network_test_url>
        <no_alt_platform>0</no_alt_platform>
        <no_gpus>0</no_gpus>
        <no_info_fetch>0</no_info_fetch>
        <no_opencl>0</no_opencl>
        <no_priority_change>0</no_priority_change>
        <os_random_only>0</os_random_only>
        <process_priority>-1</process_priority>
        <process_priority_special>-1</process_priority_special>
<proxy_info>
    <socks_server_name></socks_server_name>
    <socks_server_port>80</socks_server_port>
    <http_server_name></http_server_name>
    <http_server_port>80</http_server_port>
    <socks5_user_name></socks5_user_name>
    <socks5_user_passwd></socks5_user_passwd>
    <http_user_name></http_user_name>
    <http_user_passwd></http_user_passwd>
    <no_proxy></no_proxy>
</proxy_info>
        <rec_half_life_days>10.000000</rec_half_life_days>
        <report_results_immediately>0</report_results_immediately>
        <run_apps_manually>0</run_apps_manually>
        <save_stats_days>30</save_stats_days>
        <skip_cpu_benchmarks>0</skip_cpu_benchmarks>
        <simple_gui_only>0</simple_gui_only>
        <start_delay>0.000000</start_delay>
        <stderr_head>0</stderr_head>
        <suppress_net_info>0</suppress_net_info>
        <unsigned_apps_ok>0</unsigned_apps_ok>
        <use_all_gpus>1</use_all_gpus>
        <use_certs>0</use_certs>
        <use_certs_only>0</use_certs_only>
        <vbox_window>0</vbox_window>
    </options>
</cc_config>
 

If this page takes an hour to load, reduce posts per page to 20 in your settings, then the tinpot 486 Einstein uses can handle it.

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 4,745
Credit: 17,667,412,247
RAC: 5,897,207

This is what you have entered

This is what you have entered which is wrong.

 <device_name>test<device_name>  missing delimiter

This is what it needs to be:

 <device_name>test</device_name>

 

San-Fernando-Valley
San-Fernando-Valley
Joined: 16 Mar 16
Posts: 262
Credit: 7,152,144,928
RAC: 15,773,904

 

  <client_download_url>https://boinc.berkeley.edu/download.php</client_download_url>
        <device_name>test<device_name>
        <disallow_attach>0</disallow_attach>

 

have a look   --  where is the /        ?

cheers

Ian&Steve C.
Ian&Steve C.
Joined: 19 Jan 20
Posts: 3,703
Credit: 34,560,583,430
RAC: 41,763,850

Keith Myers wrote:This is

Keith Myers wrote:

This is what you have entered which is wrong.

 <device_name>test<device_name>  missing delimiter

This is what it needs to be:

 <device_name>test</device_name>

+1 to this. Spotted it right away.
 

Close tags always need </> in XML (unless it’s a single element with no parameter). Notice how every other one has that? It’s not a coincidence. 

_________________________________________________________________________

Mr P Hucker
Mr P Hucker
Joined: 12 Aug 06
Posts: 819
Credit: 481,409,762
RAC: 2,206

It's more complicated than

It's more complicated than that.  I only forgot the / once, I know what it's for.

Initially I entered it using Boinctasks.  Anyone with Boinctasks, give it a go.  It doesn't like the open tag at all, and highlights it in red.

When I then tried manually, I forgot the /, which is odd as I've entered tags millions of times and never forgotten.  I was probably steaming too much at the ears by then.

Now if I open the config I've made manually into Boinctasks, the whole line disappears!  I'll report it to Boinctasks, it's either his program or a problem with Boinc taking instructions to change config files remotely.  I know Boinc itself does weird things like adding gpu usage into app config when you're putting in details for a CPU only task.

If this page takes an hour to load, reduce posts per page to 20 in your settings, then the tinpot 486 Einstein uses can handle it.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.