Gravitational Wave search O2 All-Sky search ("O2AS20-500")

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 0

There're only a few days of

There're only a few days of data left in this search.  Is the next one going to be ready in time, or will there be a gap in available tasks?

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,297
Credit: 246,178,712
RAC: 10,583

DanNeely wrote:There're only

DanNeely wrote:
There're only a few days of data left in this search.  Is the next one going to be ready in time, or will there be a gap in available tasks?

There has been some swiching back and forth between finishing the "original" run (up to 500Hz) and the "extension" (beyond 500Hz), which apparently still confuses the progress display. In the "original" run there is "work" left for at least another week (400k WUs, at currently ~30k/d), and after that we will finish the extension, which will take another few months. I'll try to fix the progress display, thanks for asking.

BM

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 0

There're only a few days

There're only a few days showing on the progress meter, I think it needs another thumping.

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,297
Credit: 246,178,712
RAC: 10,583

We completed our GPU port of

We completed our GPU port of the GW app such that it can now also process the current O2AS tasks efficiently. There is now a GPU version of the O2AS20-500 app available for Beta testing.

BM

solling2
solling2
Joined: 20 Nov 14
Posts: 219
Credit: 1,569,639,331
RAC: 56,383

However, the linux 1.02

However, the linux 1.02 version seems to need a little bit of polishing...

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 463
Credit: 257,957,147
RAC: 0

I am trying to run 1.02 on a

I am trying to run 1.02 on a Radeon RX 570 (Win7 64-bit, 18.9.3 drivers).  But the GPU shows 0 percent usage.  All the work is being done by the CPU.  And after reaching 7% complete, the work unit looped back to zero the first time I tried it. 

Now on a second run it is up to 10% complete, and I hope that it will finish.  But it looks like the time will be about the same as for a CPU work unit.

 

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 463
Credit: 257,957,147
RAC: 0

solling2 wrote:However, the

solling2 wrote:
However, the linux 1.02 version seems to need a little bit of polishing...

I tried it on a GTX 1060 running under Ubuntu 18.04, and it immediately errored out.

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,297
Credit: 246,178,712
RAC: 10,583

Hm. That didn't work as

Hm. That didn't work as expected. Retracted for now.

BM

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,297
Credit: 246,178,712
RAC: 10,583

The problem with the Linux

The problem with the Linux app version should be fixed now, version 1.03 will be out soon. This probably doesn't fix the problem of the computation being mostly done on the CPU, but it should help me to analyze the problem why it's not using the GPU.

BM

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,297
Credit: 246,178,712
RAC: 10,583

App version 1.04 is the first

App version 1.04 is the first that actually does what we intended - it does (almost) all computing on the GPU. Version 1.05 contains a workaround for a problem in most AMD drivers. So far we couldn't find out what in our App is triggering that.

BM

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.