Gravitational Wave search O2 All-Sky search ("O2AS20-500")

floyd
floyd
Joined: 12 Sep 11
Posts: 133
Credit: 186,610,495
RAC: 0

Jim1348 schrieb:After

Jim1348 wrote:
After starting up and running for 8 minutes, the estimated time remaining jumps up to a very high value, typically 7 to 9 days and briefly even more.  Then, after running for maybe half an hour or so, the time estimate returns to a reasonable value.

Do you use app_config? My guess is that fraction_done_exact could cause this.

Zalster
Zalster
Joined: 26 Nov 13
Posts: 3,117
Credit: 4,050,672,230
RAC: 0

floyd_7 wrote:Jim1348

floyd_7 wrote:
Jim1348 wrote:
After starting up and running for 8 minutes, the estimated time remaining jumps up to a very high value, typically 7 to 9 days and briefly even more.  Then, after running for maybe half an hour or so, the time estimate returns to a reasonable value.
Do you use app_config? My guess is that fraction_done_exact could cause this.

 

That is weird.  I use an app_config but I'm not seeing that. Looking at some right now, there are anywhere from 11 minutes to 3 minutes in and no change in time to complete. Also not seeing a shift in priority of work. I have Einstein on the CPU, GPUGrid and Seti on the GPUs. No alterations of how they are processing.

Could it be due to the OS?  Running windows 7, i7 5960X

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 463
Credit: 257,957,147
RAC: 0

floyd_7 wrote:Do you use

floyd_7 wrote:
Do you use app_config? My guess is that fraction_done_exact could cause this.

Yes, I do indeed.  I will eliminate that, and post if it does not fix it.  Thanks.  I have never seen it before.

Betreger
Betreger
Joined: 25 Feb 05
Posts: 988
Credit: 1,494,933,170
RAC: 712,505

What causes some of these to

What causes some of these to go into pending status?

archae86
archae86
Joined: 6 Dec 05
Posts: 3,152
Credit: 7,129,674,931
RAC: 553,886

Betreger wrote:What causes

Betreger wrote:
What causes some of these to go into pending status?

I, too am curious as to how these are handled.  My first return is still pending, while all but the most recent other returned have validated.

Mine have arrived as single replication.  Is this only done for trusted hosts, or are all WUs initially going to a single host?

Some of mine have sat for over a day returned but not validated.  Is the validator running in big batches, or in such small batches that it is effective running continuously at the moment?

My (two) which are returned but pending both list Status as "Complete, waiting for validation", while the corresponding WU page states simply "Tasks are pending for this workunit."  without listing either my returned task, or (if one exists) a second try sent to someone else. The Task page lists Validation state as "initial". What outcomes can a validator pass have?  I assume pass and fail are options, but is there a "maybe".  In which cases is an additional task copy sent to another host?  What status can we see if that has happened and is pending?  Is it intentional that we can't see a checkout task in this case?  If the "maybe" option exists, what happens if the second task returns an effectively identical result.

All this is just my curiosity.  The answers may be well-known to those who have been running gravity CPU' tasks recently, but I've only been running pulsar GPU tasks, so the behavior is new to me.

 

 

 

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 463
Credit: 257,957,147
RAC: 0

Zalster wrote:That is weird. 

Zalster wrote:

That is weird.  I use an app_config but I'm not seeing that. Looking at some right now, there are anywhere from 11 minutes to 3 minutes in and no change in time to complete. Also not seeing a shift in priority of work. I have Einstein on the CPU, GPUGrid and Seti on the GPUs. No alterations of how they are processing.

Could it be due to the OS?  Running windows 7, i7 5960X

Possibly.  I was running that on an Ubuntu 16.04 machine.  But after taking out fraction_done_exact, it cured the problem immediately.

Gary Roberts
Gary Roberts
Moderator
Joined: 9 Feb 05
Posts: 5,869
Credit: 113,086,146,617
RAC: 36,250,070

Jim1348 wrote:... after

Jim1348 wrote:
... after taking out fraction_done_exact, it cured the problem immediately.

I believe this may be something to do with the use (or not) of some sort of simulated progress until the first checkpoint is written.  I'm not sure, but maybe the Einstein app shows zero progress for a while, maybe until the first checkpoint is written.  If you are using fraction_done_exact, and there is no simulated %done (ie zero progress) for some initial period,  this could translate to a huge estimate for the full crunch time - a divide by zero type scenario.

Maybe this situation changes with different BOINC versions which might explain why some people have a problem and others don't.  I suspect it's not directly to do with the OS.

Cheers,
Gary.

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 463
Credit: 257,957,147
RAC: 0

Gary Roberts wrote:I believe

Gary Roberts wrote:
I believe this may be something to do with the use (or not) of some sort of simulated progress until the first checkpoint is written.

That is certainly it.  Einstein shows a very small amount of progress (about 1%) for many minutes, and of course fraction_done_exact then extrapolates that to a very large remaining time value.  It all makes perfect sense, I just had never put it together before.

Guiri-1
Guiri-1
Joined: 8 Mar 05
Posts: 8
Credit: 83,309
RAC: 0

Hi, Will we have some mor

Hi,

 

Will we have some more info about these units? (O2AS20-500).

 

It is not shown in server_status , it would be nice ot see how many wor units do we have, how many are done...etc (like we have for rest of units).

 

Thx¡

Javi

MarkJ
MarkJ
Joined: 28 Feb 08
Posts: 437
Credit: 138,949,566
RAC: 2,031

Guiri-1_Andalucia_ wrote:It

Guiri-1_Andalucia_ wrote:

It is not shown in server_status , it would be nice ot see how many wor units do we have, how many are done...etc (like we have for rest of units).

 

Thx¡

Javi

Its on the right side of the server status page, if you look at the headings there is a column for O2AS20-500 under Workunits and Tasks.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.