GPU work and Gamma-ray pulsar binary search #1 on GPUs v1.13

Mike Davies
Mike Davies
Joined: 12 Mar 11
Posts: 10
Credit: 20,267,936
RAC: 18,319
Topic 203790

None of my work on "Gamma-ray pulsar binary search #1 on GPUs v1.13 (FGRPopencl-ati) x86_64-pc-linux-gnu " is working. After about 26 or 27 seconds of CPU work it fails compiling the OpenCL.

A log (typically https://einsteinathome.org/task/595454737) fails like ...

15:44:47 (8615): [debug]: Set up communication with graphics process.
boinc_get_opencl_ids returned [0x1b47610 , 0x7f1f8d03a430]
Using OpenCL platform provided by: Advanced Micro Devices, Inc.
Using OpenCL device "Juniper" by: Advanced Micro Devices, Inc.
Max allocation limit: 134217728
OpenCL compiling FAILED! : -11 . Error message: "/tmp/OCLgCW5YO.cl", line 10: error: identifier "double2" is undefined
  __kernel void test( __global double2 *vec) {
                               ^

1 error detected in the compilation of "/tmp/OCLgCW5YO.cl".
Frontend phase failed compilation.

OpenCL device has no FP64 support
% Opening inputfile: ../../projects/einstein.phys.uwm.edu/LATeah2003L.dat

I have never had problems before, and SETI is happy. So it looks like something new with this particular Einstein application.

I don't really understand though. The application seems to be saying my OpenCL does not support 64 bit. But if I "clinfo | grep 64" I have the extensions cl_khr_fp64 & cl_amd_fp64, so I don't really know what it is complaining about or why.

Anyone got any useful advice ?

Holmis
Joined: 4 Jan 05
Posts: 1,118
Credit: 805,086,368
RAC: 174,734

I think the error message

I think the error message refers to your GPU/driver not being able to do double precision floating point calculations.

I would try to update the graphics driver.

Mike Davies
Mike Davies
Joined: 12 Mar 11
Posts: 10
Credit: 20,267,936
RAC: 18,319

Ha Ha. You are right !! My

Ha Ha. You are right !! My driver does not have 64bit support.

If I had looked in the correct part of the clinfo report I would have seen it was not there. Now I know where to look and what to fix.

Thanks for the reply.

Later...

 

Looks like my hardware is obsolete. Current (latest) driver only supports up to XServer 1.10. I'm on XServer 1.17. Seems that my GPU will no longer be able to help einstein.

AgentB
AgentB
Joined: 17 Mar 12
Posts: 915
Credit: 513,211,304
RAC: 0

Mike Davies wrote:Looks like

Mike Davies wrote:
Looks like my hardware is obsolete.

Correct  - Juniper does not support DP.   For a list see wiki

I think HD 5830 (Cypress) and later cards do support DP.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.