Einstein@Home GPU/APU Application for AMD/ATI Graphics Cards: discussion thread

terencewee*
terencewee*
Joined: 3 Jan 12
Posts: 13
Credit: 15,295,446
RAC: 0

Thanks Oliver. 11.11 is

Thanks Oliver.

11.11 is the latest WHQL driver from AMD for FirePro m7820.

I'm downloading 12.4a mobility and will mod, install and report back whether the problem persists.

terencewee*
Sicituradastra.

Gaurav Khanna
Gaurav Khanna
Joined: 8 Nov 04
Posts: 42
Credit: 18,544,602,006
RAC: 13,671,220

If someone manages to get

If someone manages to get everything working smoothly on 64-bit Ubuntu 10 (10.04 or 10.10), please do let me know. I think I'm having trouble because I want to stick to these. I have tried a number of things since yesterday and I can't seem to get BOINC 7.0.27 to return that I have a working OpenCL platform / driver.

Oliver, HB .. what distribution / version of Linux have you folks been using / testing on?

Thanks,
Gaurav

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 873
Credit: 25,165,115
RAC: 0

RE: Oliver, HB .. what

Quote:
Oliver, HB .. what distribution / version of Linux have you folks been using / testing on?

Debian stable/squeeze x86_64.

Just to make sure, you have a running X server that the BOINC client can access (required by the ATI OpenCL platform)? Does clinfo return info about the device in question?

Oliver

 

Einstein@Home Project

Gaurav Khanna
Gaurav Khanna
Joined: 8 Nov 04
Posts: 42
Credit: 18,544,602,006
RAC: 13,671,220

Yes. clinfo works and my own

Yes. clinfo works and my own OpenCL codes work fine. The same machine was doing fine with Ubuntu 11.04 for several months on Albert. I downgraded to 10.10 and now I can't get it to work!

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 873
Credit: 25,165,115
RAC: 0

Hi Gaurav, You also want

Hi Gaurav,

You also want to make sure that there is only one instance of the 32-bit OpenCL runtime library installed and in scope of our application. There might be remnants from earlier APP SDK installations that interfere with the latest Catalyst installation - a bug I already reported to AMD. You want to check it like this:
find /usr -name "libOpenCL*" | xargs file

Check which library instance gets used by our application:
ldd /projects/einstein.phys.uwm.edu/einsteinbinary_BRP4_1.24_i686-pc-linux-gnu__atiOpenCL

Oliver

 

Einstein@Home Project

Gaurav Khanna
Gaurav Khanna
Joined: 8 Nov 04
Posts: 42
Credit: 18,544,602,006
RAC: 13,671,220

find /usr -name "libOpenCL*"

find /usr -name "libOpenCL*" | xargs file
/usr/lib32/libOpenCL.so.1: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped
/usr/lib/libOpenCL.so.1: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped

ldd einsteinbinary_BRP4_1.24_x86_64-pc-linux-gnu-eah__atiOpenCL
linux-gate.so.1 => (0xf778a000)
libOpenCL.so.1 => /usr/lib32/libOpenCL.so.1 (0xf7768000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf774e000)
libm.so.6 => /lib32/libm.so.6 (0xf7728000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf763d000)
libc.so.6 => /lib32/libc.so.6 (0xf74e2000)
/lib/ld-linux.so.2 (0xf778b000)
libdl.so.2 => /lib32/libdl.so.2 (0xf74de000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf74c1000)

This looks good. The issue is really with BOINC that it refuses to report that I have an OpenCL supported device/driver.

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 461,162,989
RAC: 39,285

Hi! This reminds me a bit

Hi!

This reminds me a bit about a problem we had at Albert, where (64 bit) BOINC client would "see" an OpenCL card, but the 32 bit app failed to see it.

The alleged solution was, somewhat surprisingly, that installing some X11 and other graphics related 32 bit compatibility libs fixed this, even tho they were not (directly) required by the app.

http://albert.phys.uwm.edu/forum_thread.php?id=8886&nowrap=true#112040

Just an idea.... maybe the OpenCL 32 bit runtime requires those.

Worth a try I'd guess.

CU
HB

EDIT: Gaurav, those other OpenCL applications that ARE working on your system, those are all 64 bit execs, right?

Gaurav Khanna
Gaurav Khanna
Joined: 8 Nov 04
Posts: 42
Credit: 18,544,602,006
RAC: 13,671,220

HB .. looks like I already

HB .. looks like I already have those 32-bit libs:

ldd einsteinbinary_BRP4_1.00_graphics_i686-pc-linux-gnu
linux-gate.so.1 => (0xf771b000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf76e6000)
libm.so.6 => /lib32/libm.so.6 (0xf76bf000)
libdl.so.2 => /lib32/libdl.so.2 (0xf76bb000)
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf759e000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf758e000)
libGL.so.1 => /usr/lib32/mesa/libGL.so.1 (0xf753b000)
libGLU.so.1 => /usr/lib32/libGLU.so.1 (0xf74cb000)
libc.so.6 => /lib32/libc.so.6 (0xf736f000)
/lib/ld-linux.so.2 (0xf771c000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf7355000)
libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf7351000)
libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf734b000)
libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf7345000)
libdrm.so.2 => /lib32/libdrm.so.2 (0xf733a000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf724f000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7233000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf722f000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7229000)
librt.so.1 => /lib32/librt.so.1 (0xf721f000)

My own OpenCL apps .. I compiled and tested both the 32-bit & 64-bit versions yesterday. They work fine.

Oliver Behnke
Oliver Behnke
Moderator
Administrator
Joined: 4 Sep 07
Posts: 873
Credit: 25,165,115
RAC: 0

That looks all good indeed!

That looks all good indeed! Gaurav, please enable coproc_debug in your BOINC client configuration. You should see additional output in the BOINC client's event log after restarting it.

Oliver

 

Einstein@Home Project

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 461,162,989
RAC: 39,285

Gaurav, I'm terribly sorry

Gaurav, I'm terribly sorry that I missed this in your original message, but....did you upgrade your BOINC client to 7.0.27? I think that host is still on 7.0.26, and the minimum version for the ATI app on Einstein is (unlike at Albert) 7.0.27!

Unfortunately, the boinc.berkeley.edu server is currently down.

CU
HB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.