BRP4 Intel GPU app feedback thread

Retvari Zoltan
Retvari Zoltan
Joined: 4 Aug 05
Posts: 6
Credit: 475,167,853
RAC: 2

RE: @Bernd: I now have a

Quote:
@Bernd: I now have a Skylake CPU with an HD530 GPU. So far the system has not produced a single valid WU! Crunched 16. An example is this one. It happened under Win 8.1 and Win 10. Using the most current driver and the one before that, which Win 10 installed automatically. Can you look into this? Is there anything else I can try?


I have three hosts with i5-6400, but none of them produced a single valid GPU WU.
The driver I'm using is the latest one from Intel. (15.40.7.4279) The OS is Windows 10 x64 pro build 10240.
http://einsteinathome.org/host/12086241/tasks&offset=0&show_names=1&state=0&appid=19
http://einsteinathome.org/host/12086260/tasks&offset=0&show_names=1&state=0&appid=19
http://einsteinathome.org/host/12086250/tasks&offset=0&show_names=1&state=0&appid=19

ExtraTerrestrial Apes
ExtraTerrestria...
Joined: 10 Nov 04
Posts: 770
Credit: 427,431,026
RAC: 3,048

I ran the test posted earlier

I ran the test posted earlier for Beigenet. The results from Skylake are very very different from the reference results. No wonder they don't validate. I have sent this to Intel support about a week ago. They seemed friendly and willing to help, but no result in sight yet.

BTW: my HD530 also hardly ever reaches its top clock speed of 1150 MHz. The average clock speed is between 1196 and 1104 MHz, depending on the load being run. HWiNFO64 shows "Fuses Limit" as the reason for the performance throttling. I have no idea what this means or what I can do to reach the advertised clock speed. It can't have anything to do with power consumption or current limits, because I already changed those.

MrS

Scanning for our furry friends since Jan 2002

Dayle Diamond
Dayle Diamond
Joined: 25 Jul 13
Posts: 3
Credit: 188,241,233
RAC: 15

Any recommendations for

Any recommendations for projects that are currently using Skylake GPUs?

Retvari Zoltan
Retvari Zoltan
Joined: 4 Aug 05
Posts: 6
Credit: 475,167,853
RAC: 2

In the meantime I've found

In the meantime I've found driver version 15.36.26.4294 and 15.40.10.4300.
I'm using the latter one, which says it's for Intel's NUC, but it's works for my i5-6400.
This host has 3 validated opencl intel gpu workunits and one invalid so far.

ExtraTerrestrial Apes
ExtraTerrestria...
Joined: 10 Nov 04
Posts: 770
Credit: 427,431,026
RAC: 3,048

33 invaluds vs. 26 valids,

33 invaluds vs. 26 valids, currently. Much better than 100% invalids, but still pretty bad. My Skylake is happily crunching SETI for now, although I'm not happy with that and would rather run Einstein.

MrS

Scanning for our furry friends since Jan 2002

ExtraTerrestrial Apes
ExtraTerrestria...
Joined: 10 Nov 04
Posts: 770
Credit: 427,431,026
RAC: 3,048

I also tested driver

I also tested driver 15.40.10.4300 and the result is still significantly different from the references. It's good that you're not crunching with this one any further, Zoltan.

MrS

Scanning for our furry friends since Jan 2002

MarkJ
MarkJ
Joined: 28 Feb 08
Posts: 437
Credit: 125,149,196
RAC: 191,026

I've raised a support request

I've raised a support request with Intel and pointed them to this message thread.

I'm using HD Graphics 530 currently on the 4352 driver under Win7 x64. I also have validation issues with it over at Seti.

It took a while to get working drivers for the HD Graphics 4000 and the HD Graphics 4600. I'm not sure if Intel have an OpenCL test suite. There is OpenCL conformance via Khronos. The Khronos website mentions a Win7 x64 driver for the Skylake series being OpenCL 2.0 compliant 2015-10-24. See Khronos Conformance

MarkJ
MarkJ
Joined: 28 Feb 08
Posts: 437
Credit: 125,149,196
RAC: 191,026

Got a response from Intel

Got a response from Intel that basically says contact the OEM, then the final paragraph states to contact the app developer. Looks like all they want to do is pass the buck.

ExtraTerrestrial Apes
ExtraTerrestria...
Joined: 10 Nov 04
Posts: 770
Credit: 427,431,026
RAC: 3,048

I also tried 4352, but it

I also tried 4352, but it doesn't look good: 4 invalid, 3 undecided, 0 valid. It works fine at SETI, though. And that response from Intel is really disappointing. Their current GPU is clearly returning calculation result which are "too wrong" under certain OpenCL usage cases. The OEM changes neither Intels chip nor their OpenCL routines.

If you haven't already done so it would benice if you told them the following:
- so far the issue affects ALL Skylake GPUs, independent of the maker
- the code works fine on other Intel GPUs, AMDs and nVidias
- in my service request I even pointed them to the source code of the app and offline testing instructions. The case was "elevated", but then I never heard anything else from them

MrS

Scanning for our furry friends since Jan 2002

ExtraTerrestrial Apes
ExtraTerrestria...
Joined: 10 Nov 04
Posts: 770
Credit: 427,431,026
RAC: 3,048

Update: 7 of 7 invalid.

Update: 7 of 7 invalid.

Scanning for our furry friends since Jan 2002

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.