BRP4 1.28 OpenCL and CUDA app : feedback thread

ForumsProblems and Bug Reports

Bikeman _Heinz-Bernd Eggenstein_
Bikeman (Heinz-...
Joined: 28 Aug 06
Posts: 3501
Credit: 150725834
RAC: 57100
Topic 196484

This thread is for discussing problems (or any other feedback if you like) related to the app BRP4 version 1.28 OpenCL for ATI/AMD graphics cards

transient
transient
Joined: 3 Jun 05
Posts: 62
Credit: 37471291
RAC: 26858

BRP4 1.28 OpenCL and CUDA app : feedback thread

This is a report not a problem. :)

Runtimes on a HD5770, 2 tasks at a time.
[pre]
App Average of Count of
Run Time(s) results
Binary Radio Pulsar Search (Arecibo) v1.24 (opencl-ati) 14490.90 38
Binary Radio Pulsar Search (Arecibo) v1.28 (opencl-ati) 6105.84 7
[/pre]

Quite in improvement, I would say. Next step would be collecting a few more results on the 1.28 app, after that reverting to running one task at a time.

Alex
Alex
Joined: 1 Mar 05
Posts: 437
Credit: 47787761
RAC: 473

Today I installed latest

Today I installed latest AMD-drivers 12.8. Runtimes on my HD6950 increased from ~3200 sec's (2wu's) to ~3770 sec's (2 wu's).
Will switch back to 12.6

Ageless
Ageless
Joined: 26 Jan 05
Posts: 2940
Credit: 5374792
RAC: 0

App v1.28 halved both my GPU

App v1.28 halved both my GPU and CPU run times. From ~4,600 seconds GPU and ~750 seconds CPU to ~2,300 seconds GPU and ~370 seconds CPU. Thumbs up. AMD HD6850, 2GB.

Jord

JHMarshall
JHMarshall
Joined: 24 Jul 12
Posts: 12
Credit: 88363054
RAC: 25906

Alex, Saw the same problem

Alex,

Saw the same problem with 12.8 -> increased run times. I run Win7 64bit. I don't know why but I changed from "Balanced" performance to "High" performance under "Power Options" and saw run times return to the 12.6 values. This was on Milky Way at Home. I haven't timed Einstein yet.

Joe

Mad_Max
Mad_Max
Joined: 2 Jan 10
Posts: 65
Credit: 20769804
RAC: 859

After update E@H OpenCL

After update E@H OpenCL application from 1.24 to version 1.28 error with the lack of free memory at once disappeared (which confirms that the problem was not in amount of free RAM, but a bug - in the application or in the AMD drivers or probably both).

But 1.28 app still not working - just another error in all Wus:
http://einsteinathome.org/host/2896418/tasks
[15:51:43][3012][ERROR] Error during OpenCL kernel setup: HSFFB (error: -5)
[15:51:43][3012][ERROR] Demodulation failed (error: 2019)!
(0x7e3) - exit code 2019 (0x7e3)
or
[16:51:34][6032][ERROR] Error during OpenCL kernel setup: TSMP_T (error: -5)
[16:51:34][6032][ERROR] Demodulation failed (error: 2019)!
(0x7e3) - exit code 2019 (0x7e3)

And POEM@Home OpenCL app still work fine on same hard&soft:
http://boinc.fzk.de/poem/results.php?hostid=109617

P.S.
Errors with free RAM (in 1.24 version) described in another topic:
http://einsteinathome.org/node/196325&nowrap=true#118714
http://einsteinathome.org/node/196325&nowrap=true#118752

Ageless
Ageless
Joined: 26 Jan 05
Posts: 2940
Credit: 5374792
RAC: 0

RE: But 1.28 app still not

Quote:
But 1.28 app still not working - just another error in all Wus:


Actually, it's the same error. Before you also had exit code 2019 on all your tasks.

For the developers, so far I've found that this exit code 2019 is the same as There was an error while deleting the color transform. (0x7e3) - exit code 2019 (0x7e3) that I had on Albert. Ask Oliver how he fixed that.

Jord

enginerd
enginerd
Joined: 9 Feb 05
Posts: 20
Credit: 4307082
RAC: 0

still no dice for me on

still no dice for me on HD5670/winXP32.
I get the same "color transform" error #2019 from the earlier 1.24 app.
fyi

7.0.28

There was an error while deleting the color transform. (0x7e3) - exit code 2019 (0x7e3)

Activated exception handling...
[11:53:20][3960][INFO ] Starting data processing...
[11:53:22][3960][INFO ] Using OpenCL platform provided by: Advanced Micro Devices, Inc.
[11:53:22][3960][INFO ] Using OpenCL device "Redwood" by: Advanced Micro Devices, Inc.
[11:53:22][3960][INFO ] Checkpoint file unavailable: status.cpt (No such file or directory).
------> Starting from scratch...
[11:53:22][3960][INFO ] Header contents:
------> Original WAPP file: ./p2030.20101226.G193.96-00.20.C.b4s0g0.00000_DM151.20
------> Sample time in microseconds: 65.4762
------> Observation time in seconds: 274.62705
------> Time stamp (MJD): 55556.179870079133
------> Number of samples/record: 0
------> Center freq in MHz: 1214.289551
------> Channel band in MHz: 0.33605957
------> Number of channels/record: 960
------> Nifs: 1
------> RA (J2000): 61508.1564999
------> DEC (J2000): 163727.051001
------> Galactic l: 0
------> Galactic b: 0
------> Name: G193.96-00.20.C
------> Lagformat: 0
------> Sum: 1
------> Level: 3
------> AZ at start: 0
------> ZA at start: 0
------> AST at start: 0
------> LST at start: 0
------> Project ID: --
------> Observers: --
------> File size (bytes): 0
------> Data size (bytes): 0
------> Number of samples: 4194304
------> Trial dispersion measure: 151.2 cm^-3 pc
------> Scale factor: 0.00137665
[11:53:25][3960][INFO ] Seed for random number generator is 1168041574.
[11:53:34][3960][INFO ] Derived global search parameters:
------> f_A probability = 0.08
------> single bin prob(P_noise > P_thr) = 1.32531e-008
------> thr1 = 18.139
------> thr2 = 21.241
------> thr4 = 26.2686
------> thr8 = 34.6478
------> thr16 = 48.9581
[11:53:41][3960][ERROR] Error during OpenCL kernel setup: PS_R3 (error: -5)
[11:53:41][3960][ERROR] Demodulation failed (error: 2019)!
11:53:41 (3960): called boinc_finish

]]>

Alex
Alex
Joined: 1 Mar 05
Posts: 437
Credit: 47787761
RAC: 473

You're using XP, so pls check

You're using XP, so pls check your driver-version

http://einsteinathome.org/node/196325&nowrap=true#118752

Mad_Max
Mad_Max
Joined: 2 Jan 10
Posts: 65
Credit: 20769804
RAC: 859

RE: RE: But 1.28 app

Quote:
Quote:
But 1.28 app still not working - just another error in all Wus:

Actually, it's the same error. Before you also had exit code 2019 on all your tasks.

For the developers, so far I've found that this exit code 2019 is the same as There was an error while deleting the color transform. (0x7e3) - exit code 2019 (0x7e3) that I had on Albert. Ask Oliver how he fixed that.


Hmm, you right.
More exactly - at 1.24 app was 2 errors:
-Demodulation failed (error: 2013)! - this related to bug with lack of free RAM (when lot of free RAM actually)
-Demodulation failed (error: 2019)!

At 1.28 app first error (2013) gone, but 2019 still persist.

paul_135
paul
Joined: 22 Jun 08
Posts: 1
Credit: 1179693
RAC: 0

I run einstein in the

I run einstein in the background & pause it when I need to do processor intensive work. I recently started getting WU's for the gpu but these won't pause when I need to do graphics intensive work. The Boinc manager tasks status is listed as suspended, but the task keeps on using the gpu. I had to abort the task to get on with work. Do you have any suggestions so that I won't have to continue to abort opencl-ati-lion tasks?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.