Application setting 'S6 Bucket = no' not honored

Christoph
Christoph
Joined: 25 Aug 05
Posts: 41
Credit: 5,954,206
RAC: 0
Topic 195803

Hello,

I want to let you know that my settings S6 = no are not working. During my last work fetch I got S6 work.

Since I want to help with the S5 clean up BRP and S6 are set to 'No'.

Boinc 6.12.26 x64 for Windows

If I remember correctly, this version does honor this setting. Or was that the scheduler code?

Greetings, Christoph

tolafoph
tolafoph
Joined: 14 Sep 07
Posts: 122
Credit: 71,048,647
RAC: 75,126

Application setting 'S6 Bucket = no' not honored

The easiest way to get only S5 work is an app.info file with only the S5 application in it.

Bernd wrote in the S5 clean-up thread:

Quote:

I'd expect the S6 checkbox being checked (S6 processing enabled) and changing of it being disabled (greyed out). Everything else would be a surprise to me.

In any case the current "locality" scheduler that is used for GW Applications such as S5GC1HF and S6Bucket has a bug that leads to this setting being ignored anyway for these applications.

S5GC1HF was the first GW run where we enabled the opt-out because of the data volume (download, disk space, RAM usage) involved. We didn't notice that this didn't work at all until we revisited the scheduler code a couple of days ago.

We are re-designing and (partly) re-writing the locality scheduler code anyway, but this will take some time. For the time being, opting out of S6Bucket is only possible by using anonymous platform (app_info.xml).

S6Bucket should have way lower requirements than S5GC1HF had, so I hope this is not too much of a problem.

BM

Edit: Just yesterday I set up a new host with i7-2600 CPU and an app.info file. It works fine, but the traffic is high because you get only a few tasks per frequency but the host has to download a lot for that.

edit 2: But before usind that app.info you should finish/aboard all tasks!!! I forgot about that and now the S6 tasks I got on the new host have to time out.

Christoph
Christoph
Joined: 25 Aug 05
Posts: 41
Credit: 5,954,206
RAC: 0

Thaks for the reply. I did

Thaks for the reply. I did remember reading something about it, but not where.
I will run down my current tasks and then write up an app_info. Should have enough examples, running opti app over at seti when running it.

Greetings, Christoph

tolafoph
tolafoph
Joined: 14 Sep 07
Posts: 122
Credit: 71,048,647
RAC: 75,126

You should also delete any S6

You should also delete any S6 files from your Einstein@home folder and the blocks for those files from the client_state.xml

Before I did that I got error messages about not having the S6Bucket app in my app.info file. And didn´t get any S5 work.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.