All things RX 500 series (460/560/570/580)

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

Thank you. I probably have an

Thank you. I probably have an Linux reinstall coming up. I prefer get and go driver installs.

Tom M

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

cecht wrote:Just to follow up

cecht wrote:
Just to follow up on the AMD vs Ubuntu 20.04.2 Linux kernel problem, I too ran into all the headaches described here, but found something that works with the newest kernels when I do upgrades. 

Note to self.  You STILL have to unplug the system from the Internet to get the 5.4 Kernel to install.  And get the original Amd gpu drivers to install.  Darn it!

I used to be able to tell the installer not to install any upgrade during the install and it would install 5.4

That appears to no longer work.  You have to unplug it from the Internet.

Tom M

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 458
Credit: 233,122,964
RAC: 430

Tom M wrote: cecht

Tom M wrote:

cecht wrote:
Note to self.  You STILL have to unplug the system from the Internet to get the 5.4 Kernel to install.  And get the original Amd gpu drivers to install.  Darn it!

Nothing is for sure with AMD.  Of two more or less identical RX 570 machines, only one worked with the procedure that I used successfully below.   The other one doesn't, no matter how much I downgrade the kernel.  So I have to do a complete reinstall, with cable unplugged, or wait for new drivers that work with the new kernels.  With the warmer weather, I may do the latter.  I have plenty of Nvidia cards.  They work. 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

So far the version of windows

So far the version of windows 10 drivers that are working for me ( finally) are dated 20.11.3 64 bit Nov 30.

The two most current drivers both produced either stalled behavior or computation failures.

Tom M

 

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

I may have just successfully

I may have just successfully bios flashed one of my XFX Rx 580 8 GB.  It is still running a Gamma Ray task more than 23 seconds after starting.

Hurray...  Jumping up and down in (what I hope is NOT) preliminary excitement...

Tom M

 

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

I may have just successfully

I may have just successfully bios flashed one of my XFX Rx 580 8 GB.  It is still running a Gamma Ray task more than 23 seconds after starting.

Hurray...  Jumping up and down in (what I hope is NOT) preliminary excitement...

Tom M

 

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

Tom M wrote: I may have just

Tom M wrote:

I may have just successfully bios flashed one of my XFX Rx 580 8 GB.  It is still running a Gamma Ray task more than 23 seconds after starting.

Hurray...  Jumping up and down in (what I hope is NOT) preliminary excitement...

Tom M

Flashed my 2nd Rx 580 using the same ROM file.

It looks like both are good to go with 3 gpu threads per gpu.

No hiccups (yet).

Tom M

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Jim1348
Jim1348
Joined: 19 Jan 06
Posts: 458
Credit: 233,122,964
RAC: 430

There is a new driver (21.10)

There is a new driver (21.10) out for Ubuntu 20.04.2.

Has anyone tried it yet?  I have an RX 570 on the 20.50 driver, and it is working fine.

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

Jim1348 wrote: There is a

Jim1348 wrote:

There is a new driver (21.10) out for Ubuntu 20.04.2.

Has anyone tried it yet?  I have an RX 570 on the 20.50 driver, and it is working fine.

Given that drivers don't (usually) make much of a performance difference I would be leary of breaking a working system.

A test system is born to be broken.  But not your production system.

Tom M

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Tom M
Tom M
Joined: 2 Feb 06
Posts: 2,442
Credit: 4,134,508,817
RAC: 9,019,503

Hurray! I finally have an

Hurray!

I finally have an (apparently stable) dual Rx 580 system that is again on the uptick running single-threaded E@H Gamma Ray, PrimeGrid (CPU), and World Community Grid (CPU).

My current guess is it might top out around 1,100,000 RAC on single GPU tasks.  Once it does and continues to be stable I will experiment with 2-3 tasks per GPU.  The goal (of course) is to see if I can work something out that puts it into the top 50.

Tom M

Live long and Prosper.

A proud member of the O.F.A. (Old Farts Association)

It ain't the heat it's the humility. - Yogi Berra

 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.