Upgrading BOINC

Brass Tilde
Brass Tilde
Joined: 20 Feb 05
Posts: 1
Credit: 283,555
RAC: 0
Topic 190320

Is there a recommended upgrade method? I have 4.19, and I'd like to upgrade to the current. Is it an "uninstall and reinstall" or "upgrade in place" thing? Will my current settings stick, or will I need to enter new ones?

MarkF
MarkF
Joined: 12 Apr 05
Posts: 393
Credit: 1,516,715
RAC: 0

Upgrading BOINC

check out the problems and bug reports forum. The thread you are looking for is pinned to the top at number 2.

Stick
Stick
Joined: 24 Feb 05
Posts: 790
Credit: 2,147,882
RAC: 460

RE: Is there a recommended

Quote:
Is there a recommended upgrade method? I have 4.19, and I'd like to upgrade to the current. Is it an "uninstall and reinstall" or "upgrade in place" thing? Will my current settings stick, or will I need to enter new ones?

I believe the new 5.2.X BOINC's will not upgrade directly over v.4.19. However, I think you can upgrade in 2 steps. First, download and install BOINC 4.45, then download and install BOINC 5.2.13.

Gary Roberts
Gary Roberts
Moderator
Joined: 9 Feb 05
Posts: 4,886
Credit: 29,148,276,713
RAC: 35,312,012

RE: I believe the new 5.2.X

Message 20806 in response to message 20805

Quote:
I believe the new 5.2.X BOINC's will not upgrade directly over v.4.19.

Yes, that is correct and is mentioned in the "sticky" thread about upgrading.

Quote:
However, I think you can upgrade in 2 steps. First, download and install BOINC 4.45, then download and install BOINC 5.2.13.

This is not needed and may still fail in trying to install 4.45 over 4.19. The correct procedure is to simply use Windows to uninstall 4.19 first. This will leave all the configuration and data files in place and then 5.2.x will find all this stuff when it is installed.

For anyone still unsure about the details please read these instructions carefully before you start.

Cheers,
Gary.

Ageless
Joined: 26 Jan 05
Posts: 2,949
Credit: 5,374,792
RAC: 0

RE: RE: However, I think

Message 20807 in response to message 20806

Quote:
Quote:
However, I think you can upgrade in 2 steps. First, download and install BOINC 4.45, then download and install BOINC 5.2.13.

This is not needed and may still fail in trying to install 4.45 over 4.19. The correct procedure is to simply use Windows to uninstall 4.19 first.


This is the correct procedure.

BOINC 4.19 was the old version, where the daemon and the GUI were one package. You need to uninstall it completely before you can install any higher version (from 4.20 onwards).

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.