Problem with a R9 390X when run 2 or more WUs at a time.

Gary Roberts
Gary Roberts
Moderator
Joined: 9 Feb 05
Posts: 5,417
Credit: 54,128,587,132
RAC: 74,583,250

It may not be as slow as you

It may not be as slow as you fear. I would guess you may be able to get more than 80% of the 2x throughput. Because of the default 'reservation' of a full CPU core when running GPU tasks 2x on AMD GPUs, you may get sub-optimal performance on the GPU at 1x if you don't also 'reserve' a core here as well. It's certainly worth testing out if it makes any difference to GPU times if one CPU core is kept free.

It's easy to do that, either with an app_config.xml file or by changing preferences for the number of cores BOINC is allowed to use. I use the former because all CPU cores can be used if there isn't a GPU task running. This could be useful if you support multiple projects.

Cheers,
Gary.

Chooka
Chooka
Joined: 11 Feb 13
Posts: 103
Credit: 1,462,801,243
RAC: 4,655,633

Hi Gary, I do reserve 1

Hi Gary,

I do reserve 1 core for GPU WU's. If I don't, no cores available and no load on the GPU.
Shame the 2 WU issue hasn't been resolved.

Oh well.


Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 1,932,011,719
RAC: 263

I too believe the problem is

I too believe the problem is the driver. Have several issues with new AMD drivers (since 7/2015), especially on MW@H, which is now causing excessive CPU usage and BSODs sometimes. This didn't happen before, unfortunately I can't downgrade the drivers back to 2014 because of Win10.
AMD should release new Catalyst Omega drivers in November, so let's hope those will work better.

-----

Sasa Jovicic
Sasa Jovicic
Joined: 17 Feb 09
Posts: 75
Credit: 42,787,136
RAC: 6,507

I think the problem is not in

I think the problem is not in the driver. R9 280X uses the same driver and works without problems. I think the problem is in the hardware. Maybe it would not be bad about this problem inform AMD. Firmware patch could solve this problem.

astrocrab
astrocrab
Joined: 28 Jan 08
Posts: 208
Credit: 429,202,534
RAC: 0

any news? my r9 nano is

any news? my r9 nano is getting bored because of idle

AgentB
AgentB
Joined: 17 Mar 12
Posts: 915
Credit: 513,211,304
RAC: 0

Has anyone tried the 15.10

Has anyone tried the 15.10 beta drivers here?

astrocrab
astrocrab
Joined: 28 Jan 08
Posts: 208
Credit: 429,202,534
RAC: 0

i did

i did

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 463,794,684
RAC: 9,477

Has anyone who experienced

Has anyone who experienced this problem earlier tried whether it is still a problem with current drivers? I did see some invalids when running more than one task before, now I'm running this configuration:

Radeon Software Version - 15.12
Radeon Software Edition - Crimson
Graphics Chipset - AMD Radeon HD 7700 Series
Memory Size - 1024 MB
Memory Type - GDDR5
Core Clock - 1075 MHz
Windows Version - Windows 10
System Memory - 8 GB
CPU Type - Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz

and so far all seems fine again.

HBE

juan BFP
juan BFP
Joined: 18 Nov 11
Posts: 839
Credit: 421,443,712
RAC: 0

Aparently the problem only

Aparently the problem only apears on the Hawaii GPU (Rx 390x, FuryX, etc)

lHj2ixL.jpg

 

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 463,794,684
RAC: 9,477

RE: Aparently the problem

Quote:
Aparently the problem only apears on the Hawaii GPU (Rx 390x, FuryX, etc)

OK, was it fixed in the meantime? Maybe the problem on my card was a different one, still I'd be interested to hear from people who had the problem before.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.