All things Navi 10

Gavin
Gavin
Joined: 21 Sep 10
Posts: 191
Credit: 35,037,146,380
RAC: 790,147

Ondra-[at]-SpaceFamily.CZ

Ondra-[at]-SpaceFamily.CZ wrote:

So, I just got my 5700XT 2 days ago, and the results are pretty concerning to me.

3 tasks were marked as valid and 3 tasks were marked as invalid. However, the valid tasks were marked as valid only when compared to a result from a system with another 5700XT!

This workunit: https://einsteinathome.org/workunit/426141023 and this workunit: https://einsteinathome.org/workunit/426059969 are such examples.

I am pausing my computations as I'm worried that my results are actually invalid. I don't want my PC to produce results that are bad for the project.

There is still a problem unknown with these cards and Gamma Ray work. As you have discovered, tasks completed with a 5700 will only validate if partnered with another machine with a 5700 and without the app developers input there is no way of knowing if these validated tasks have any scientific worth. 

You don't need to suspend computations just switch your prefernces to allow Gravitational Wave search O2 Multi-Directional GPU instead, this search is the one I am having great success with. I have also now been cruching tasks x2 for 24 hours without issue and have seen a nice productivity boost too!

Gav.

 

cecht
cecht
Joined: 7 Mar 18
Posts: 1,084
Credit: 1,608,952,246
RAC: 2,415,680

update: Check Gavin's post on

update: Check Gavin's post on another forum. From the link he provides for his Window's host with a RX 5700 XT, GW tasks running at 4x with the v2.02 app are being consistently validated by both NVIDIA and non-Navi ATI hosts.

Ideas are not fixed, nor should they be; we live in model-dependent reality.

Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 2,245,175,206
RAC: 7,179

No luck with the 5700 XT,

No luck with the 5700 XT, even with latest Adrenalin 2020 drivers.
Gamma-ray pulsar binary search produces all results as Invalid.
GW tasks all end up with Error.

-----

Gavin
Gavin
Joined: 21 Sep 10
Posts: 191
Credit: 35,037,146,380
RAC: 790,147

Hi Mumak, The Gamma-ray work

Hi Mumak,

The Gamma-ray work validation issue is long standing and yet to be resolved by either AMD or the Einstein dev's being able to identify the problem and compensate accordingly. The only time this work type validates is if you are partnered with another 5700 XT host but just because two 5700 XT's agree doesn't mean the science output is actually good!

My 5700 XT has been cruching the Gravitational Wave work near flawlessly for a couple of months or more now (I did pick up a TIME_LIMIT_EXCEEDED error like yours a couple of days back). The machine is currently set for x4 multiplicity, cpu usage is high and average gpu load is ~72%.

I'm using driver version 19.10.2 if that helps :-)

Gav.

 

Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 2,245,175,206
RAC: 7,179

Thanks for the information

Thanks for the information Gavin. I heard about this issue on SETI some time ago, but thought it was resolved meanwhile. I don't know why GW doesn't work either, never had much luck with this app as it was usually running quite ineffective. But this time it's a 100% fail.

-----

Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 2,245,175,206
RAC: 7,179

Has anyone tried the new

Has anyone tried the new Radeon Adrenalin 2020 19.12.3 drivers if these maybe fix the issue? This package seems to contain a lot of fixes.

-----

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 2,409
Credit: 6,749,314,460
RAC: 23,843,514

Still not fixed.  But as

Still not fixed.  But at least finally acknowledged by AMD and is now on the "known issues" list.  Bottom entry.

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-19-12-3

 

Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 2,245,175,206
RAC: 7,179

That's good news, thanks

That's good news, thanks Keith for spotting that! I usually read release notes, but skipped this section this time :-)

-----

Gavin
Gavin
Joined: 21 Sep 10
Posts: 191
Credit: 35,037,146,380
RAC: 790,147

Thanks for your input Keith

Thanks for your input Keith :-)

As I appear to be the only one (reporting) having success with any type of work on this card that is good news indeed and lets hope AMD can resolve whatever is causing the problems. It would be great to test the true potential of the RX 5xxx series cards.

I've not been following the driver updates since my card started working with the GW app early October time and I have been loathe to update because (for whatever reason) it works for me. Since then I've not wanted to risk breaking it again!
I'm currently happy my investment is no longer sat idle and is contibuting to good science but I am desperate to retry the Gamma Ray app as it is not so cpu bound and will be easier to measure relative performance against my other cards (if AMD or Einstein can iron out the wrinkles, of course).

Gav.

 

Mumak
Joined: 26 Feb 13
Posts: 325
Credit: 2,245,175,206
RAC: 7,179

From my tests the Navi10 XTX

From my tests the Navi10 XTX performs slightly slower than my Vega10 XT: 350 vs 320 secs running 1 task. But the Vega10 has power limit reduced by 20%, so the real difference is a bit larger.

-----

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.