Windows S5R2 App 4.30 available for Beta Test

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,276
Credit: 245,612,084
RAC: 10,665

The 4.30 has been made

The 4.30 has been made "official".

However, minutes after that I saw a Client Error from 4.30 Beta Test tumbling in that allowed to track down a cause for our major Client Error (a General Access Violation that lists "houghmap.c" in the stackdump) and hopefully fix it. A new Beta will soon be published (no individual speedup, but less client errors).

BM

BM

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,276
Credit: 245,612,084
RAC: 10,665

The new Beta App is

The new Beta App is there!

Thank you very much for this Beta Test!

BM

BM

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 5

hmmm I thought the server'd

hmmm I thought the server'd been updated to push the new app out to already queued WUs on the client end. Is there anything in particular I need to kick to get it running on my end?

Dave Burbank
Dave Burbank
Joined: 30 Jan 06
Posts: 275
Credit: 1,548,376
RAC: 0

The WU's in your cache have

The WU's in your cache have been assigned to be crunched by the new app even though in BOINC it says they're still assigned to an older app. Only newly assigned work will say 'using app 4.30' under your tasks.

Just to make sure double check in task manager, it should show that the beta app is running.

There are 10^11 stars in the galaxy. That used to be a huge number. But it's only a hundred billion. It's less than the national deficit! We used to call them astronomical numbers. Now we should call them economical numbers. - Richard Feynman

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 5

Nope, it's not even

Nope, it's not even downloaded. Clients are running 5.8.11, .15, and .16. All have been manually updated but none have DLed the 4.30 app.

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 5

RE: Nope, it's not even

Message 70543 in response to message 70542

Quote:
Nope, it's not even downloaded. Clients are running 5.8.11, .15, and .16. All have been manually updated but none have DLed the 4.30 app.

4.30's been DLed on all boxes with new work, but they're still running 4.24 for prior WUs (checked via task mangler).

Gary Roberts
Gary Roberts
Moderator
Joined: 9 Feb 05
Posts: 5,852
Credit: 111,114,675,454
RAC: 34,809,571

RE: 4.30's been DLed on all

Message 70544 in response to message 70543

Quote:
4.30's been DLed on all boxes with new work, but they're still running 4.24 for prior WUs (checked via task mangler).

This is entirely normal behaviour. When there is a project generated app change (eg 4.24 -> 4.30) the results will be crunched with the app specified at the time the result was downloaded.

When using the beta app with a current style app_info.xml, it's the intelligence in the app_info.xml which overrides the "branding" of each result and allows any result (no matter how branded) to be crunched with the particular app specified in the app_info.xml file. If you really want any 4.24 "branded" results to be crunched with 4.30 you will need to use the app_info.xml mechanism. If you are even thinking about going to that amount of trouble, you may as well use 4.32 and be done with it :).

Cheers,
Gary.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.