Problems uploading

[KWSN]John Galt 007
[KWSN]John Galt 007
Joined: 28 Apr 10
Posts: 2
Credit: 7,020,602
RAC: 0

Here is a snip of my most

Here is a snip of my most recent upload attemp:

5/5/2010 8:53:42 AM [http_debug] HTTP_OP::libcurl_exec(): ca-bundle 'C:\Program Files\BOINC\ca-bundle.crt'
5/5/2010 8:53:42 AM [http_debug] HTTP_OP::libcurl_exec(): ca-bundle set
5/5/2010 8:53:42 AM Einstein@Home Started upload of p2030_53910_24357_0109_G58.54-00.71.C_3.dm_328_1_1
5/5/2010 8:53:42 AM Einstein@Home [file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/cgi-bin/file_upload_handler
5/5/2010 8:53:42 AM [http_debug] [ID#85] info: timeout on name lookup is not supported
5/5/2010 8:53:42 AM [http_debug] [ID#85] info: About to connect() to einstein-dl.aei.uni-hannover.de port 80 (#14)
5/5/2010 8:53:42 AM [http_debug] [ID#85] info: Trying 130.75.116.202...
5/5/2010 8:54:03 AM [http_debug] [ID#85] info: Timed out
5/5/2010 8:54:03 AM [http_debug] [ID#85] info: Failed connect to einstein-dl.aei.uni-hannover.de:80; No error
5/5/2010 8:54:03 AM [http_debug] [ID#85] info: Expire cleared
5/5/2010 8:54:03 AM [http_debug] [ID#85] info: Closing connection #14
5/5/2010 8:54:03 AM [http_debug] HTTP error: Couldn't connect to server
5/5/2010 8:54:04 AM Project communication failed: attempting access to reference site
5/5/2010 8:54:04 AM [http_debug] HTTP_OP::init_get(): http://www.google.com/
5/5/2010 8:54:04 AM [http_debug] HTTP_OP::libcurl_exec(): ca-bundle set
5/5/2010 8:54:04 AM Einstein@Home [file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -107
5/5/2010 8:54:04 AM Einstein@Home [file_xfer_debug] file transfer status -107
5/5/2010 8:54:04 AM Einstein@Home Temporarily failed upload of p2030_53910_24357_0109_G58.54-00.71.C_3.dm_328_1_1: connect() failed
5/5/2010 8:54:04 AM Einstein@Home Backing off 1 hr 0 min 3 sec on upload of p2030_53910_24357_0109_G58.54-00.71.C_3.dm_328_1_1
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: Connection #8 seems to be dead!
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: Closing connection #8
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: timeout on name lookup is not supported
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: About to connect() to www.google.com port 80 (#8)
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: Trying 72.14.204.147...
5/5/2010 8:54:04 AM [http_debug] [ID#86] info: Connected to www.google.com (72.14.204.147) port 80 (#8)
5/5/2010 8:54:04 AM [http_debug] [ID#86] Sent header to server: GET / HTTP/1.1
User-Agent: BOINC client (windows_x86_64 6.10.17)
Host: www.google.com
Accept: */*
Accept-Encoding: deflate, gzip
Content-Type: application/x-www-form-urlencoded

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: HTTP/1.1 200 OK

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Date: Wed, 05 May 2010 13:54:20 GMT

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Expires: -1

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Cache-Control: private, max-age=0

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Content-Type: text/html; charset=ISO-8859-1

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Set-Cookie: PREF=ID=d35bde5d3595d01b:TM=1273067660:LM=1273067660:S=XoC--iehnBWa12PV; expires=Fri, 04-May-2012 13:54:20 GMT; path=/; domain=.google.com

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Server: gws

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: X-XSS-Protection: 1; mode=block

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server: Transfer-Encoding: chunked

5/5/2010 8:54:04 AM [http_debug] [ID#86] Received header from server:

5/5/2010 8:54:04 AM [http_xfer_debug] HTTP: wrote 1049 bytes
5/5/2010 8:54:04 AM [http_xfer_debug] HTTP: wrote 1430 bytes
5/5/2010 8:54:04 AM [http_xfer_debug] HTTP: wrote 1430 bytes
5/5/2010 8:54:04 AM [http_xfer_debug] HTTP: wrote 187 bytes
5/5/2010 8:54:05 AM [http_xfer_debug] HTTP: wrote 1425 bytes
5/5/2010 8:54:05 AM [http_xfer_debug] HTTP: wrote 1025 bytes
5/5/2010 8:54:05 AM [http_debug] [ID#86] info: Expire cleared
5/5/2010 8:54:05 AM [http_debug] [ID#86] info: Connection #8 to host www.google.com left intact
5/5/2010 8:54:05 AM Internet access OK - project servers may be temporarily down.

MarkJ
MarkJ
Joined: 28 Feb 08
Posts: 410
Credit: 66,092,921
RAC: 89

File_xfer_debug

File_xfer_debug says...

5/05/2010 11:52:06 PM Einstein@Home [file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -184
5/05/2010 11:52:06 PM Einstein@Home [file_xfer_debug] file transfer status -184
5/05/2010 11:52:06 PM Einstein@Home Temporarily failed upload of p2030_53905_24642_0054_G51.33-00.98.C_2.dm_256_2_3: HTTP error
5/05/2010 11:52:06 PM Einstein@Home [file_xfer_debug] project-wide xfer delay for 60.000000 sec
5/05/2010 11:52:06 PM Einstein@Home Backing off 1 min 0 sec on upload of p2030_53905_24642_0054_G51.33-00.98.C_2.dm_256_2_3
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval 0
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] parsing upload response: 0
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] parsing status: 0
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] file transfer status 0
5/05/2010 11:52:27 PM Einstein@Home Finished upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_0
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] Throughput 55 bytes/sec
5/05/2010 11:52:27 PM Einstein@Home [fxd] starting upload, upload_offset 0
5/05/2010 11:52:27 PM Einstein@Home Started upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_1
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/cgi-bin/file_upload_handler
5/05/2010 11:52:27 PM Einstein@Home [fxd] starting upload, upload_offset 0
5/05/2010 11:52:27 PM Einstein@Home Started upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_2
5/05/2010 11:52:27 PM Einstein@Home [file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/cgi-bin/file_upload_handler
5/05/2010 11:53:38 PM Einstein@Home [file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -184
5/05/2010 11:53:38 PM Einstein@Home [file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -184
5/05/2010 11:53:38 PM Einstein@Home [file_xfer_debug] file transfer status -184
5/05/2010 11:53:38 PM Einstein@Home Temporarily failed upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_1: HTTP error
5/05/2010 11:53:38 PM Einstein@Home Backing off 1 min 0 sec on upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_1
5/05/2010 11:53:38 PM Einstein@Home [file_xfer_debug] file transfer status -184
5/05/2010 11:53:38 PM Einstein@Home Temporarily failed upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_2: HTTP error
5/05/2010 11:53:38 PM Einstein@Home Backing off 1 min 0 sec on upload of p2030_53931_17569_0040_G45.06+00.77.C_0.dm_300_1_2

Richard Haselgrove
Richard Haselgrove
Joined: 10 Dec 05
Posts: 1,935
Credit: 204,887,605
RAC: 93,361

NOW you see why David and

NOW you see why David and Jord keep saying "set the flags, send me the logs"!

I make that a combination of

[http_debug] HTTP error: Server returned nothing (no headers, no data)
[file_xfer_debug] file transfer status -184


and

[http_debug] [ID#85] info: Timed out
[file_xfer_debug] file transfer status -107


It's not DNS.

We had a big problem with "Server returned nothing (no headers, no data)" at SETI recently: I dug out a copy of WireShark and confirmed that the server was actually sending back connection reset ([RST]) packets. That was a sick server: it was managing a few file transfers, but far, far fewer than it should normally have been capable of handling. SETI have cured it, but unfortunately the admins never actually posted to say what was wrong and what they did to fix it. Perhaps Bernd could have a quiet word with Matt, Jeff or Eric and pick up some hints?

diederiks
diederiks
Joined: 30 Jul 05
Posts: 3
Credit: 2,184,683
RAC: 280

I'm having upload and

I'm having upload and download problems for the last week or so, some files get downloaded after a few times, others already have treid dozens of times without succes.

Gundolf Jahn
Gundolf Jahn
Joined: 1 Mar 05
Posts: 1,079
Credit: 341,280
RAC: 0

RE: 05-May-2010 07:35:57

Message 97889 in response to message 97883

Quote:
05-May-2010 07:35:57 [---] [http_debug] [ID#0] Sent header to server: POST /cgi-bin/file_upload_handler HTTP/1.1


It's been a long time, so I almost forgot about my fight with HTTP errors, but when I saw this line, I recalled that I switched to HTT protocol 1.0 and since haven't had any such problems.

    
        1
    


Gruß,
Gundolf

BTW, could anyone please remove the extra newline from the [pre][/pre] clause handling, on occasion?

Computer sind nicht alles im Leben. (Kleiner Scherz)

diederiks
diederiks
Joined: 30 Jul 05
Posts: 3
Credit: 2,184,683
RAC: 280

I have treid the OpenDNS

I have treid the OpenDNS solution and HTTP 1.0 in cc_config.xml but i have found no improvement in up- or downloading to this project, all other projects are working as normal.

archae86
archae86
Joined: 6 Dec 05
Posts: 2,792
Credit: 3,089,903,878
RAC: 2,904,751

This one looks different from

This one looks different from my first, though it is a Windows 7 system running BOINGCmgr 5.10.20, rather than the 5.10.45 on the other:

	Host	Project	Date	Message
	Acer1	Einstein@Home	5/5/2010 10:36:41 AM	[file_xfer] Started upload of file p2030_53768_59204_0086_G62.76-00.47.C_5.dm_420_3_0
	Acer1	---	5/5/2010 10:36:41 AM	[file_xfer_debug] PERS_FILE_XFER::start_xfer(): URL: http://einstein-dl.aei.uni-hannover.de/cgi-bin/file_upload_handler
	Acer1	---	5/5/2010 10:36:41 AM	[http_debug] [ID#0] info: About to connect() to einstein-dl.aei.uni-hannover.de port 80 (#0)
	Acer1	---	5/5/2010 10:36:41 AM	[http_debug] [ID#0] info:   Trying 130.75.116.202...
	Acer1	---	5/5/2010 10:37:03 AM	[http_debug] [ID#0] info: Timed out
	Acer1	---	5/5/2010 10:37:03 AM	[http_debug] [ID#0] info: Failed connect to einstein-dl.aei.uni-hannover.de:80; No error
	Acer1	---	5/5/2010 10:37:03 AM	[http_debug] [ID#0] info: Expire cleared
	Acer1	---	5/5/2010 10:37:03 AM	[http_debug] [ID#0] info: Closing connection #0
	Acer1	---	5/5/2010 10:37:03 AM	[http_debug] HTTP error: couldn't connect to server

which differs from the next try on the same host:

	Host	Project	Date	Message
	Acer1	Einstein@Home	5/5/2010 10:41:56 AM	[file_xfer] Started upload of file p2030_53904_23095_0039_G43.28-01.00.C_1.dm_296_0_1
	Acer1	---	5/5/2010 10:41:56 AM	[file_xfer_debug] PERS_FILE_XFER::start_xfer(): URL: http://einstein-dl.aei.uni-hannover.de/cgi-bin/file_upload_handler
	Acer1	---	5/5/2010 10:41:57 AM	[http_debug] [ID#2] info: About to connect() to einstein-dl.aei.uni-hannover.de port 80 (#0)
	Acer1	---	5/5/2010 10:41:57 AM	[http_debug] [ID#2] info:   Trying 130.75.116.202...
	Acer1	---	5/5/2010 10:42:06 AM	[http_debug] [ID#2] info: Connected to einstein-dl.aei.uni-hannover.de (130.75.116.202) port 80 (#0)
	Acer1	---	5/5/2010 10:42:06 AM	[http_debug] [ID#2] Sent header to server: POST /cgi-bin/file_upload_handler HTTP/1.1
User-Agent: BOINC client (windows_intelx86 5.10.20)
Host: einstein-dl.aei.uni-hannover.de
Accept: */*
Accept-Encoding: deflate, gzip
Content-Type: application/x-www-form-urlencoded
Content-Length: 304
	Acer1	---	5/5/2010 10:42:51 AM	[http_debug] [ID#2] info: Empty reply from server
	Acer1	---	5/5/2010 10:42:51 AM	[http_debug] [ID#2] info: Closing connection #0
	Acer1	---	5/5/2010 10:42:51 AM	[http_debug] HTTP error: server returned nothing (no headers, no data)

The next three fails on this same host were all of the "timed out, Failed connect, Expire cleared" flavor, not the "empty reply" flavor.

Gundolf Jahn
Gundolf Jahn
Joined: 1 Mar 05
Posts: 1,079
Credit: 341,280
RAC: 0

RE: I have tried the

Message 97892 in response to message 97890

Quote:
I have tried the OpenDNS solution and HTTP 1.0 in cc_config.xml but i have found no improvement in up- or downloading to this project, all other projects are working as normal.


Yes, today I got a new ABP task and got HTTP errors, too, although I still have active. I have file_xfer_debug logging enabled and saw retvals of -107 (system connect) and -184 (http error), but finally all files were successfully downloaded.

Here an excerpt for one file (of the many):

05/05/2010 11:34:04|Einstein@Home|[sched_op_debug] Starting scheduler request
05/05/2010 11:34:04|Einstein@Home|Sending scheduler request: To fetch work.  Requesting 165 seconds of work, reporting 0 completed tasks
05/05/2010 11:34:10|Einstein@Home|Scheduler request succeeded: got 1 new tasks
05/05/2010 11:34:10|Einstein@Home|[sched_ops_debug] Server version 611
05/05/2010 11:34:10|Einstein@Home|Project requested delay of 60.000000 seconds
05/05/2010 11:34:10|Einstein@Home|[sched_op_debug] Deferring communication for 1 min 0 sec
05/05/2010 11:34:10|Einstein@Home|[sched_op_debug] Reason: requested by project

05/05/2010 11:34:12|Einstein@Home|Started download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:34:12||[file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/EinsteinAtHome/download/37b/p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:34:34||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -107
05/05/2010 11:34:34||[file_xfer_debug] file transfer status -107
05/05/2010 11:34:34|Einstein@Home|Temporarily failed download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary: system connect
05/05/2010 11:34:34|Einstein@Home|Backing off 1 min 0 sec on download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary

05/05/2010 11:37:34|Einstein@Home|Started download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:37:34||[file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/EinsteinAtHome/download/37b/p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:39:08||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval -184
05/05/2010 11:39:08||[file_xfer_debug] file transfer status -184
05/05/2010 11:39:08|Einstein@Home|Temporarily failed download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary: http error
05/05/2010 11:39:08|Einstein@Home|Backing off 1 min 0 sec on download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary

05/05/2010 11:41:32|Einstein@Home|Started download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:41:32||[file_xfer_debug] URL: http://einstein-dl.aei.uni-hannover.de/EinsteinAtHome/download/37b/p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:42:03||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval 0
05/05/2010 11:42:03||[file_xfer_debug] file transfer status 0
05/05/2010 11:42:03|Einstein@Home|Finished download of p2030_53701_70269_0165_G37.35-01.66.N_3_236.binary
05/05/2010 11:42:03|Einstein@Home|[file_xfer_debug] Throughput 68848 bytes/sec


Gruß,
Gundolf

Computer sind nicht alles im Leben. (Kleiner Scherz)

FalconFly
FalconFly
Joined: 16 Feb 05
Posts: 191
Credit: 15,650,710
RAC: 0

I'm also having massive

Message 97893 in response to message 97892

I'm also having massive Problems Up- or Downloading on all Systems that are connected through a Proxy - all other projects work fine.

My only direct connnected machine works like a charm, though.

They all have the cc_config.xml enabled with the old Proxy workaround (BOINC otherwise fails to connect to projects for me)

1

archae86
archae86
Joined: 6 Dec 05
Posts: 2,792
Credit: 3,089,903,878
RAC: 2,904,751

RE: I have file_xfer_debug

Message 97894 in response to message 97892

Quote:
I have file_xfer_debug logging enabled and saw retvals of -107 (system connect) and -184 (http error), but finally all files were successfully downloaded.

While I have seen plenty of download retries, the mean time to success may be less than for uploads.

At this moment, to illustrate, I have 150 uploads in retry across my little flotilla, but no downloads in that state.

As something about the situation seems to be suppressing most download requests (my queues have shrunk a lot), I wondered whether the lack of retries might just reflect a lack of request. So I triggered a download by doing an update on a host which actually had a ready to report or two. The four files to download all failed on first try, but within about five minutes all four had succeeded, so averaging perhaps two or three retries each. That seems much, much better than I'm getting on uploads currently.

One other observation--although this trouble has been going on for days, it appears to me not to be stable, but to be getting progressively, albeit fitfully, worse.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.