no more cuda work?

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 4,831
Credit: 17,986,645,376
RAC: 3,299,834

I already run an app_info.

I already run an app_info. Always have for all my projects.

Keith

 

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 4,831
Credit: 17,986,645,376
RAC: 3,299,834

RE: There is a simple

Quote:
There is a simple setting on the prefs screen to just do GPU work on E@H. Yes, if you enable the CPU, you will get S6, but you don't have to do anything with your app_info to only do GPU units.

That's the problem. I only have work for GPU's checked on my preferences page. No CPU work is set. Doesn't matter ...... the S6 work is set for Yes and no way to modify it.

Keith

 

Keith Myers
Keith Myers
Joined: 11 Feb 11
Posts: 4,831
Credit: 17,986,645,376
RAC: 3,299,834

RE: RE: Also I notice

Quote:
Quote:
Also I notice that I have a greyed out checkmark for the Gravitational Wave S6 GC work. That probably explains the error messages. I never opted for this work. I can't change the value by editing, it remains a greyed out checkmark in the box. I can't uncheck it. Can an administrator correct this?

Unfortunately for anyone who's only interested in GPU crunching, the the S6GC being non-disablable is by design. The money that's funding the whole E@H program comes from that research effort, with the other search efforts just riders. I'm not sure if they're explicitly not allowed to enable that checkbox, or if they're only unwilling to do so because it would just look bad with the people paying the bills. Either way the end result is the same for the rest of us.

What you can do is to use an app_info.xml file to tell the server that your computer is only able to do BRP4-cuda tasks. The caveat is that you'll need to manually update the file each time a new app comes out, and your message log will be cluttered with messages from the server saying you could get more work (S6GC, etc) if you removed the file.

My app_info only has sections for GPU work. No mention of S6 work or its app is in my app_info and yet I still get the annoying message that my app_info doesn't have a S6 application.

Quote:

einsteinbinary_BRP4
Binary Radio Pulsar Search

einsteinbinary_BRP4_1.00_windows_intelx86__BRP3cuda32.exe

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe

cudart_xp32_32_16.dll

cufft_xp32_32_16.dll

db.dev.win.3d35195e

dbhs.dev.win.3d35195e

einsteinbinary_BRP4

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe
graphics_app

einsteinbinary_BRP4
100
windows_intelx86
0.200000
1.000000
BRP3cuda32
6.13.0

einsteinbinary_BRP4_1.00_windows_intelx86__BRP3cuda32.exe

cudart_xp32_32_16.dll
cudart32_32_16.dll

cufft_xp32_32_16.dll
cufft32_32_16.dll

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe
graphics_app

db.dev.win.3d35195e
db.dev

dbhs.dev.win.3d35195e
dbhs.dev

CUDA
.5

 

DanNeely
DanNeely
Joined: 4 Sep 05
Posts: 1,364
Credit: 3,562,358,667
RAC: 0

RE: My app_info only has

Quote:

My app_info only has sections for GPU work. No mention of S6 work or its app is in my app_info and yet I still get the annoying message that my app_info doesn't have a S6 application.

That's by design at the BOINC level. The server has no way to know that you don't have an S6 section because you removed it, vs because S6 didn't exist when you created the file.

KittenKaboodle
KittenKaboodle
Joined: 9 Feb 11
Posts: 13
Credit: 10,765,731
RAC: 0

RE: RE: I too can't seem

Quote:
Quote:
I too can't seem to get any BRP4 GPU work since they finished BRP3. What's up? The Tasks to Send for both BRP3 and 4 are always at 0 when I check the server status. This is what my log always shows when I contact E@H.

check your preferences page here - you need to opt in for it.

I am having problems getting BRP4 GPU WUs, too. I DO get enough WUs when I am NOT using the app_info.xml configuration file. But when I use that file, the log always will show the following entries:

30.07.2011 09:54:47 Einstein@Home Sending scheduler request: To fetch work.
30.07.2011 09:54:47 Einstein@Home Requesting new tasks for GPU
30.07.2011 09:54:49 Einstein@Home Scheduler request completed: got 0 new tasks
30.07.2011 09:54:49 Einstein@Home Message from server: To get more Einstein@Home work, finish current work, stop BOINC, remove app_info.xml file, and restart.
30.07.2011 09:54:49 Einstein@Home Message from server: No work sent

Is there any trick to get BRP4 GPU WUs when using app_info.xml?
Here is my app_info.xml:

einsteinbinary_BRP3
Binary Radio Pulsar Search

einsteinbinary_BRP4
Binary Radio Pulsar Search

einstein_S6Bucket

einstein_S6Bucket_1.01_windows_intelx86__SSE2.exe

einstein_S5R6_3.01_graphics_windows_intelx86.exe

einsteinbinary_BRP3_1.07_windows_intelx86__BRP3cuda32.exe

einsteinbinary_BRP4_1.00_windows_intelx86__BRP3cuda32.exe

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe

cudart_xp32_32_16.dll

cufft_xp32_32_16.dll

db.dev.win.3d35195e

dbhs.dev.win.3d35195e

einsteinbinary_BRP3
107
windows_intelx86
0.450000
1.000000
16098423918.034389
BRP3cuda32
6.13.0

einsteinbinary_BRP3_1.07_windows_intelx86__BRP3cuda32.exe

cudart_xp32_32_16.dll
cudart32_32_16.dll

cufft_xp32_32_16.dll
cufft32_32_16.dll

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe
graphics_app

db.dev.win.3d35195e
db.dev

dbhs.dev.win.3d35195e
dbhs.dev

CUDA
0.500000

314572800.000000

einsteinbinary_BRP4
100
windows_intelx86
0.450000
1.000000
23340214733.152119
BRP3cuda32
6.13.0

einsteinbinary_BRP4_1.00_windows_intelx86__BRP3cuda32.exe



cudart_xp32_32_16.dll
cudart32_32_16.dll



cufft_xp32_32_16.dll
cufft32_32_16.dll



einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe
graphics_app


db.dev.win.3d35195e
db.dev



dbhs.dev.win.3d35195e
dbhs.dev



CUDA
0.500000

314572800.000000

einsteinbinary_BRP3
105
windows_intelx86
0.450000
1.000000
BRP3cuda32
6.13.0

einsteinbinary_BRP3_1.07_windows_intelx86__BRP3cuda32.exe

cudart_xp32_32_16.dll
cudart32_32_16.dll

cufft_xp32_32_16.dll
cufft32_32_16.dll

einsteinbinary_BRP3_1.00_graphics_windows_intelx86.exe
graphics_app

db.dev.win.3d35195e
db.dev

dbhs.dev.win.3d35195e
dbhs.dev

CUDA
0.500000

314572800.000000

einstein_S6Bucket
101
windows_intelx86
SSE2
6.13.0

einstein_S6Bucket_1.01_windows_intelx86__SSE2.exe

einstein_S5R6_3.01_graphics_windows_intelx86.exe
graphics_app

Rechenkuenstler
Rechenkuenstler
Joined: 22 Aug 10
Posts: 138
Credit: 102,567,115
RAC: 0

That's not a matter of your

That's not a matter of your app_info file. It is because of the prpblems with the work generators. See the following to Bernd's thread.

http://einsteinathome.org/node/195884&nowrap=true#113288

KittenKaboodle
KittenKaboodle
Joined: 9 Feb 11
Posts: 13
Credit: 10,765,731
RAC: 0

But everything works (i.e I

But everything works (i.e I am getting enough BRP4 WUs) when I am not using the app_info.xml file.

Rechenkuenstler
Rechenkuenstler
Joined: 22 Aug 10
Posts: 138
Credit: 102,567,115
RAC: 0

I'm also using an app_info

I'm also using an app_info file. And everything works.

Jeroen
Jeroen
Joined: 25 Nov 05
Posts: 379
Credit: 740,030,628
RAC: 0

RE: But everything works

Quote:
But everything works (i.e I am getting enough BRP4 WUs) when I am not using the app_info.xml file.

I generally have to setup either a cron job or scheduled task to do manual updates to get new work with app_info.xml.

Linux: ./boinccmd --project http://einstein.phys.uwm.edu/ update

Windows: "C:\Program Files\BOINC\boinccmd.exe" --project http://einstein.phys.uwm.edu/ update

Rechenkuenstler
Rechenkuenstler
Joined: 22 Aug 10
Posts: 138
Credit: 102,567,115
RAC: 0

RE: RE: But everything

Quote:
Quote:
But everything works (i.e I am getting enough BRP4 WUs) when I am not using the app_info.xml file.

I generally have to setup either a cron job or scheduled task to do manual updates to get new work with app_info.xml.

Linux: ./boinccmd --project http://einstein.phys.uwm.edu/ update

Windows: "C:\Program Files\BOINC\boinccmd.exe" --project http://einstein.phys.uwm.edu/ update

That's correct. I did this too.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.