NEW: MAC OSX TEST APPLICATION FOR EINSTEIN@HOME

Bruce Allen
Bruce Allen
Moderator
Joined: 15 Oct 04
Posts: 1,111
Credit: 172,125,663
RAC: 0
Topic 189366

I haven't been having a hangup problem. But my Boinc never switches in "Run Always". I don't think it is supposed to. I think it's supposed to complete the WU due back earliest and then go to the next due back and so on and so on. The "Run Always" should not be switching app. every hour or two...whatever you have choosen in your online preferences. It should only be earliest date.

At least that is my understanding of the difference. If you have "run always" checked and your boinc is switching apps., you have more problems then you think. Or maybe I have more problem then I think.

Besides that problem, here is the one I am seeing since Einstein .11. I launch Boinc has the app. start as it should. Einstein .11 shows that 2 WUs are running and 2 Seti 4.30 are paused. The problem is that einstein .11 show 0.00% and the clocks are not moving. Neither the "To Completion" or the "CPU Time". But when I look at the Activity Viewer it shows 2 Einstein apps. running.

Of course I can exit and restart Boinc once or twice and the problem corrects itself. Nonetheless it is still buggy. I did not have this issue in Einstein.08

Boinc 4.44
Seti@home 4.30
Einstein .11

Director, Einstein@Home

alan_stafford
alan_stafford
Joined: 22 Jan 05
Posts: 69
Credit: 2,393,496
RAC: 0

NEW: MAC OSX TEST APPLICATION FOR EINSTEIN@HOME

Also installed the Superbench G4 boinc within Boinc menubar, worked fine even though I was in the middle of a work unit.

There was a log message saying change of version, then ran benchmarks, then resumed unit.

"Way Cool" - thanks to everyone involved in making this possible.

I finally feel Boinc/Einstein is using my computer to the full.
I had felt they were being a little disrespectful in the past.

I am only running Einstein so can't help as far as testing multiple projects.

Alan

Snake Doctor
Snake Doctor
Joined: 21 Jul 05
Posts: 71
Credit: 551,338
RAC: 0

RE: ... But my Boinc never

Quote:
... But my Boinc never switches in "Run Always". I don't think it is supposed to. I think it's supposed to complete the WU due back earliest and then go to the next due back and so on and so on. The "Run Always" should not be switching app. every hour or two...whatever you have choosen in your online preferences. It should only be earliest date....
Quote:

Actually my understanding was that the "run always" setting was telling the system that you are not just running in screen saver mode. This keeps the processing going even if you are doing word processing surfing the web or what ever. If you set it based on prefs it will stop processing when you start another application. As for switching, it will switch based on the time slot you enter into the prefs page on the project site. If you tell it to switch every hour it will do just that. The idea for having it switch is to change the data flow in the cpu to kind of give things a rest. If you are running a CPU intensive function like CP@H you could overheat the CPU (or so they say). I suspect that if you are not seriously over-clocking your system that it will not overheat. In any case switching is normal. If yours is not switching check your prefs on the project site. It is possible to set the switch rate so long that the APP can finish a WU before it switched and the move to the next one as you describe.

Regards
Phil


We Must look for intelligent life on other planets as,
it is becoming increasingly apparent we will not find any on our own.

Shaktai
Shaktai
Joined: 8 Nov 04
Posts: 183
Credit: 426,451
RAC: 0

Well except for the one stuck

Well except for the one stuck unit that occurred while I still had SETI units in queue, there have been no more problems. The SETI units are gone and no freezes in the last 24 hours or so. I'll keep an eye on it, and if it stays stable, then I may try and add in some Predictor units at a low resource share.

Note to self. Remember to write down the work unit number if it stalls again.

Snake Doctor
Snake Doctor
Joined: 21 Jul 05
Posts: 71
Credit: 551,338
RAC: 0

RE: ... then I may try and

Message 12635 in response to message 12634

Quote:
... then I may try and add in some Predictor units at a low resource share.

I have had good luck so far running Predictor with 011 an Climate.

Regards
Phil


We Must look for intelligent life on other planets as,
it is becoming increasingly apparent we will not find any on our own.

C
C
Joined: 9 Feb 05
Posts: 94
Credit: 189,446
RAC: 0

I had the same problem Alan

I had the same problem Alan Ng describes above, again. After running fine for about a day, the iBook seemed to hang. Activity monitor dock icon, and the graphic at the bottom of the window, showed about 80% was system (red) and the other 20% split between user (green) and nice (blue). The table in Activity Monitor showe@H using around 90%, with small amounts for many other processes. I went to the menu bar pulldown and clicked STOP. Log says it stopped, but the AM table continues to say E@H is running with 90%, and the graphic shows System continuing to use 70-80% of the CPU. Quitting MenuBar makes the E@H process go away, and when MB is restarted, everything runs fine, with E@H resuming and running as normal. I haven't actually see the .11 client hang, just discovered it when checking in the morning...but I did see the .08 hang - and it seemed to be just as E@H was requesting more work with about .5 hours to go to finish it's current WU. My "connect to" is set for .02 day so the half hour is consistent with that.

I wonder if the new WU downloaded and then starts running immediately, even though the old one still has half hour to run. This might explain why E@H appears to still run when I tell MB to stop. Two WU might be running, and only one is "controlled" by MB - and the Activity monitor might be thinking the second WU is a system function. This is, of course, pure speculation, as I don't have a clue what is actually happening...

C

C
C
Joined: 9 Feb 05
Posts: 94
Credit: 189,446
RAC: 0

One more item. I was sitting

One more item. I was sitting at the iBook when it hung again. Standard stuff: Activity Monitor graphic says System has around 70-80 %, with user and nice sharing the rest. AM table shows E@H with 90%. I clicked Stop on MenuBar and nothing stopped, although log says it stopped. Went to AM and did a Force Quit on E@H. The graphic clears, shows just a few percent for user and system and nothing else. MenuBar is still an active process, but not using CPU. I noticed this, by the way, about 25 minutes or so after the E@H contacted the server to get more work.

I next clicked Start in MenuBar to see what would happen - all previous times I had Quit MB, but this time I had not; just Stopped it. The E@H WU resumed, according to the log. The AM graphic immediately went to system showing 70% or so, and the AM table said E&H was using most of the CPU. I clicked Stop on MenuBar again, and again had to do a force quit to get the E@H WU to stop processing. Once again, I clicked Start in MB, and it resumed, then 13 seconds later said E@H finished computing that WU, started the next WU and uploaded the completed one, which is w1_1019.0__1019.0_0.1_T03_S4hA_1 , result #7245750. Activity Monitor table and graphic now agree, with most of the CPU devoted to Nice.

C

Snake Doctor
Snake Doctor
Joined: 21 Jul 05
Posts: 71
Credit: 551,338
RAC: 0

RE: ...and it seemed to be

Message 12638 in response to message 12636

Quote:

...and it seemed to be just as E@H was requesting more work

C

I think you may be on to something here. I have been thinking that a switch from one process to another might be the problem. the fact is that up-load/dn-load cycles frequently cause a switch of app on my system. Usually the up/dn-load comes at the end of a process cycle for a particular WU and so a switch occurs. So it might not be the app switch but the up/dn-load to watch for. I'll keep and eye on mine and see what happens.

I have set the prefs to "keep in memory" and it has been running for about 15 hours now at that setting and everyone seems to be playing nice. It did take a while to stabilize with this setting. This was after clearing out the E@H cue of WUs that were originally dn-loaded under 008, and cleaning up S@H queues. So far no hangs and no stalls, but I have noticed that while the message system says things have been up-loaded, they still show in the Work queue as "ready to report". So I don't think any actual upload has occurred. We'll see what happens when it does.

Regards
Phil


We Must look for intelligent life on other planets as,
it is becoming increasingly apparent we will not find any on our own.

Shaktai
Shaktai
Joined: 8 Nov 04
Posts: 183
Credit: 426,451
RAC: 0

Thing is, I have seen random

Thing is, I have seen random project switching problems all along on the menubar client. Doesn't seem to matter which project or which core client version (optimized or not). Just every now and then it locked on me. That's why I have stuck with the BOINC manager. Not perfect but at least it tells you when it is messing up.

Then again, for reliablty on the the Mac, the CLI is the way to go, if you don't mind the command line. I think the menubar and BOINC managers for Mac still need a little fine tuning.

But what do I know?

Snake Doctor
Snake Doctor
Joined: 21 Jul 05
Posts: 71
Credit: 551,338
RAC: 0

I have never run the CLI

Message 12640 in response to message 12639

I have never run the CLI client. On my G4 dual the menubar client runs better that the BOINC manager. But I prefer the Manager because you get more information and have a lot more control over the WUs and the apps. I have never found anyway to suspend a WU with the Menubar. Now for CP@H the menubar is much better because you can see each processing step. It seems to me that they should have a "Debug" mode in the client that allows you to get more detail about the running process.

After watching BOINC run for a while it seems to me that there are a number of improvements needed. Not the least of which would be the ability to control time allocations at the project level. The way it is now if you change it for on project the change propigates to all the projects over time. There should be a set of general prefs that apply to BOINC and some elements of the apps, and a set of APP specific controls that overide the general prefs, but only affect one project.

But as you said "What do I know?"

I am getting more nervous as time passes on the Beta. The system has been crunching for almost 24 hours without a hang or stall. If it makes it a full day that will be a record for my systems running 011.

Regards
Phil


We Must look for intelligent life on other planets as,
it is becoming increasingly apparent we will not find any on our own.

minervini
minervini
Joined: 31 May 05
Posts: 37
Credit: 18,274
RAC: 0

Well then I guess I am having

Well then I guess I am having serious issues. Boinc has never..I repeat NEVER switched app. while I have had my preferences set to "Run Always". What I get is a message that says "New CPU scheduler Policy: earliest deadline first." And that is just what my Boinc does, it's works on the WU that has the earliest deadline and then moves on to the next two with the earliest deadline. I have my Boinc preferences set to switch apps. every 120 minutes, but the "New CPU scheduler Policy: earliest deadline first", tell it to complete the first due back first. Which is what is happening. Maybe it has something to do with the fact that I have 10 day worth of work on or something else that I am not aware of, but that is how my Boinc has always worked. Start the WU that is due back first and finish it first before jumping to another WU. Two by two, always the earliest deadline.

The only time it switched apps. is when Einstein downloads a new batch of WUs to my machine. Because of the difference between the 7 days deadline of Einstein and the 14 day deadline of Seti.

Things that make you go hmmm!

I did have an Einstein WU freeze at 99% today. I quit Boinc and restarted and it read 100% and moved on. But the Activity Monitor said its was still crunching while I know it was finished because it had been about 20 hours and the finished WU said it finished in about 10 hours.

I think Einstein .11 has an issue WUs freezing. This is the second time .11 has done this one my machine.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.