High-Speed Linux-BRP-App for Raspberry Pi 3

N30dG
N30dG
Joined: 29 Feb 16
Posts: 89
Credit: 4,755,917
RAC: 0

PorkyPies wrote:Updated 8 of

PorkyPies wrote:

Updated 8 of them. Ended up using the in-place after watching a task get bumped out because there wasn't enough memory for the operating system to run stuff.

 

I don't have Problems to fit 4 concurrent jobs into the RAM using your setup. You should allow BOINC to use, at least 90% of RAM. I have ~150MB of free RAM left over, using your setup from above.

 

PorkyPies wrote:

#3 has thrown a couple of signal 11 errors, not sure if that means its a faulty Pi as well.

https://einsteinathome.org/task/576672632

https://einsteinathome.org/task/576542536

 

[edit]

Two minutes later and the Pi has locked up, so looks like another faulty one. Back to running the stock app on it too.

The Signal 11 means Segmentation Fault or somthink like this. Do you getting it using the in-place?

This might be a Bug in Software. But it can also be a Hardware-Problem (probably a problem with the RAM).  If you getting these Problems on other of you PI's, its definitely a bug in my App-Version. If it's only restricted to one Device I would guess it's the next faulty one :(

Please keep an eye on it and report it to me if you getting these kind of error on other devices too.

PorkyPies
PorkyPies
Joined: 27 Apr 16
Posts: 142
Credit: 7,908,511
RAC: 3,132

N30dG wrote:PorkyPies

Quote:

N30dG wrote:

I don't have Problems to fit 4 concurrent jobs into the RAM using your setup. You should allow BOINC to use, at least 90% of RAM. I have ~150MB of free RAM left over, using your setup from above.

 

PorkyPies wrote:

#3 has thrown a couple of signal 11 errors, not sure if that means its a faulty Pi as well.

https://einsteinathome.org/task/576672632

https://einsteinathome.org/task/576542536

 

[edit]

Two minutes later and the Pi has locked up, so looks like another faulty one. Back to running the stock app on it too.

The Signal 11 means Segmentation Fault or somthink like this. Do you getting it using the in-place?

This might be a Bug in Software. But it can also be a Hardware-Problem (probably a problem with the RAM).  If you getting these Problems on other of you PI's, its definitely a bug in my App-Version. If it's only restricted to one Device I would guess it's the next faulty one :(

Please keep an eye on it and report it to me if you getting these kind of error on other devices too.

https://einsteinathome.org/host/12262711/tasks

is also throwing them. I am on a bus at the moment so can't get to it for about 8 hours. Will put it back to stock as well. Thats 3 out of 9 which might indicate an app problem.

 

I have all the Pi3's set to 90% memory use (when idle). I was watching it using BOINCtasks so its considered idle by BOINC.

PorkyPies
PorkyPies
Joined: 27 Apr 16
Posts: 142
Credit: 7,908,511
RAC: 3,132

Somewhat later have got home

Somewhat later have got home and gone back to using the project supplied app. I've had to do this on 4 out of 9 of them. The other 5 seem able to run the optimised app.

N30dG
N30dG
Joined: 29 Feb 16
Posts: 89
Credit: 4,755,917
RAC: 0

PorkyPies wrote:Somewhat

PorkyPies wrote:

Somewhat later have got home and gone back to using the project supplied app. I've had to do this on 4 out of 9 of them. The other 5 seem able to run the optimised app.

 

4 out of 9 that is close to 50%. That is a lot, but the question is why some Devices can run the App just fine and others do not? As long as my PI doesn't run into this error, I'm not be able to locate the Problem. I would ask you to borrow or sell me some off your "faulty" PI's. Unfortunately your at the other side of the World and shipping would be very expencive. Shipping from Germany to Australia costs ~45 EUR, thats ~67 AUD. Thats a little bit to much.

But you can help me finding these nasty bug. You have to perform some test on your "faulty"-PI's. Only if you want to do that?

For the first could you please try to run the optimized-App on one of the "faulty"-PI's, But only at one core and finish a WU? If that doesn't work I send you a special Debug-App-Version, if it works switch two using 2cores,...

PorkyPies
PorkyPies
Joined: 27 Apr 16
Posts: 142
Credit: 7,908,511
RAC: 3,132

I'm happy to help out. I'll

I'm happy to help out. I'll contact you via PM and we can try and work through the issues.

robl
robl
Joined: 2 Jan 13
Posts: 1,598
Credit: 1,041,784,689
RAC: 364,992

I am getting errors on a Pi3

I am getting errors on a Pi3 running the new IP application.  There errors are:

 

Seed for random number generator is 1200014506.
Derived global search parameters:
------> f_A probability = 0.08
------> single bin prob(P_noise > P_thr) = 1.32531e-08
------> thr1 = 18.139
------> thr2 = 21.241
------> thr4 = 26.2686
------> thr8 = 34.6478
------> thr16 = 48.9581
Checkpoint committed!
fftw: /home/neo/BRPdebug/3rdparty/fftw/kernel/alloc.c:269: assertion failed: p

[19:49:54][1315][ERROR] Application caught signal 6.

------> Obtained 5 stack frames for this thread.
19:49:54 (1315): called boinc_finish

</stderr_txt>
]]>

 

N30dG
N30dG
Joined: 29 Feb 16
Posts: 89
Credit: 4,755,917
RAC: 0

Yes it seem's that the

Yes it seem's that the IP-Version have some Problem's. Sorry but We are working on that.

At the moment it is a little bit frustrating because I don't know what's going on... My PI3 could run both Versions just fine. And without getting the Problem's on my device it's hard to find the error.

But I'm shure We can get it :)

robl
robl
Joined: 2 Jan 13
Posts: 1,598
Credit: 1,041,784,689
RAC: 364,992

N30dG wrote:Yes it seem's

N30dG wrote:

Yes it seem's that the IP-Version have some Problem's. Sorry but We are working on that.

At the moment it is a little bit frustrating because I don't know what's going on... My PI3 could run both Versions just fine. And without getting the Problem's on my device it's hard to find the error.

But I'm shure We can get it :)

N30DG,

I know you have put a lot of effort into this but I am thinking that with the issues that are occurring it might be better to remove the download links until this can be sorted out.  New people might get turned off and start bad mouthing E@H.  Those of us who have been around a while understand what is going on but "new bees"  would not.  And I would not want E@H to be faulted.  I am sure you feel the same way.

I have two Pi 3s having problems with the IP version while the other two Pi 3s are fine.  Don't know if there is a timing issue or something else (Pi 3 vendor, OS???).  I run on Ubuntu Mate and I am running full desktop installations (why I use the IP version).  

 

PorkyPies
PorkyPies
Joined: 27 Apr 16
Posts: 142
Credit: 7,908,511
RAC: 3,132

Currently trialling the

Currently trialling the out-of-place app running 3 at a time (due to the amount of memory required for each task). If my maths is correct I think it will produce 1 task less per day than running the in-place on all 4 cores. I had zombie tasks which required a restart to get going again when the Pi runs out of memory while running 4 at a time.

Only half my Pi3's seem able to run the in-place, the others throw invalids or errors (and the occasional Pi lockup).

 

Stock app approx 42k seconds per task x 4

In-place app approx. 23.7k seconds per tasks x 4

Out-of-place app approx. 18.8k seconds per task x 3

Tomas Brada
Tomas Brada
Joined: 18 Oct 15
Posts: 5
Credit: 3,164,762
RAC: 0

It seems the floating point

It seems the floating point bug withing kernel still persist somewhere. Add panic=5 to auto reboot on kernel panic.

This app really does not work on Pi B+. I know it is written in the title, but I had to try.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.