GNU/Linux S5R3 App 4.16 available for Beta test

Annika
Annika
Joined: 8 Aug 06
Posts: 720
Credit: 494,410
RAC: 0

Yeah, then it starts the

Yeah, then it starts the debugger, and it _seems_ to be running allright, outputs some X-server related warnings, but since I get a message that if those warnings annoy me I can just switch them off I don't think they're all that serious. Maybe a problem with my graphics card or so. Btw, it looks like those two WUs will be the first ones to survive intact and get crunched to the end (Bernd and BM, you know what I mean by "V-Effekt"...)

Bikeman (Heinz-Bernd Eggenstein)
Bikeman (Heinz-...
Moderator
Joined: 28 Aug 06
Posts: 3,516
Credit: 469,049,345
RAC: 60,441

Yeah, V-Effekt indeed.

Yeah, V-Effekt indeed. Where's a decent crash when you need one :-/.

CU

H-B

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,027
Credit: 216,313,606
RAC: 91,248

RE: RE: In addition it

Message 75223 in response to message 75194

Quote:
Quote:
In addition it will stop trying to immediately sync the checkpoint file after five successive failures (which should help e.g. on XFS). And in contrast to the 4.14 will still keep the checkpoint if syncing failed.

On my XFS systems checkpointing now works (what a relief!). There are no messages about inability to sync, as if it even didn't try to sync at all ...


Are you sure you don't have a EAH_NO_SYNC file left in the BOINC directory?

BM

BM

Annika
Annika
Joined: 8 Aug 06
Posts: 720
Credit: 494,410
RAC: 0

Looks like I did it... booted

Looks like I did it... booted up my lappi and it was the end of my WUs. Hope the debugger caught it so I can finally help sort this out.

Metod, S56RKO
Metod, S56RKO
Joined: 11 Feb 05
Posts: 135
Credit: 790,956,670
RAC: 13,296

RE: RE: On my XFS systems

Message 75225 in response to message 75223

Quote:
Quote:
On my XFS systems checkpointing now works (what a relief!). There are no messages about inability to sync, as if it even didn't try to sync at all ...

Are you sure you don't have a EAH_NO_SYNC file left in the BOINC directory?

I'm pretty much sure about that. I've removed it as it didn't seem to work with 4.14 for me anyhow ...

Metod ...

Jos van Wolput
Jos van Wolput
Joined: 11 Feb 05
Posts: 47
Credit: 800,840
RAC: 0

One of three WU's crunched

One of three WU's crunched with 4.16 was terminated before completion:
http://einsteinathome.org/task/88590557
This happened in the night when the computer was doing nothing else but crunching.
I am using a laptop Intel Pentium M 1.7, kernel 2.6.22-2-686 and libc6 v.2.7 (Debian)

Annika
Annika
Joined: 8 Aug 06
Posts: 720
Credit: 494,410
RAC: 0

Looks like we're running a

Looks like we're running a similar kernel version, I'm on 2.6.22-14, also 686 I think... and the Core architecture is rather similar to the Pent M since it's the direct successor. libc 2.6.1-1(Ubuntu). What else... yeah... we're both talking about laptops, so it might even be an ACPI problem. Mysterious really ;-) Bernd, any news yet?

Bernd Machenschalk
Bernd Machenschalk
Moderator
Administrator
Joined: 15 Oct 04
Posts: 4,027
Credit: 216,313,606
RAC: 91,248

Yes, just minutes ago. The

Yes, just minutes ago.

The message "process got signal 11" is actually not from the App, but from the BOINC Core Client. Either the reason for the segfault is in the Core Client itself, or it is catching the signal meant for the App, in which case it at least prevents any further diagnosis output that might be helpful.

Please try an old Core Client. On my test machines, a 5.4.11 seems to work reliably. At least we should get a better idea of where the segfault comes from.

BM

BM

Annika
Annika
Joined: 8 Aug 06
Posts: 720
Credit: 494,410
RAC: 0

Great, I hate not being able

Great, I hate not being able to use the Ubuntu packages... yeah well... can't really be helped I guess. I'll make the change as soon as I have time.

th3
th3
Joined: 24 Aug 06
Posts: 208
Credit: 2,208,434
RAC: 0

RE: Great, I hate not being

Message 75230 in response to message 75229

Quote:
Great, I hate not being able to use the Ubuntu packages...


Download this file:
http://ftp.de.debian.org/debian/pool/main/b/boinc/boinc-client_5.4.11-4_i386.deb

Then install it:
sudo dpkg -i boinc-client_5.4.11-4_i386.deb

Hope it works

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.