Error After Upgrading BOINC

ForumsProblems and Bug Reports

x002046
x002046
Joined: 23 Feb 12
Posts: 4
Credit: 2736202
RAC: 7343
Topic 196277

After upgrading to BOINC 7.0.25, the next 2 workunits ended with status: "error while computing" after running the expected duration. Can someone give me some guidance? I suspect the current work will fail as well. Thanks. -kevin

The tasks are:

Task: 282932456 WU: 120809357 Computer: 4747273

7.0.25

The system cannot find the file specified. (0x2) - exit code 2 (0x2)

[21:41:59][592][INFO ] Starting data processing...
[21:41:59][592][INFO ] Continuing work on at template no. 0
[21:41:59][592][ERROR] Input file on command line ../../projects/einstein.phys.uwm.edu/p2030.20110428.G41.98+00.73.S.b5s0g0.00000_3160.bin4 doesn't agree with input file from checkpoint header.
[21:41:59][592][ERROR] Demodulation failed (error: 2)!
21:41:59 (592): called boinc_finish

AND

Task: 283207583 WU:120931778 Computer: 4747273

7.0.25

Incorrect function. (0x1) - exit code 1 (0x1)

x002046
x002046
Joined: 23 Feb 12
Posts: 4
Credit: 2736202
RAC: 7343

Error After Upgrading BOINC

The third WU that ran after my BOINC upgrade completed successfully and was validated. So I am concluding that these errors and the upgrade were a coincidence and are not related.

I also note that one of these errors:

Error while computing - Demodulation failed (error: 2)

was previously reported with no apparent resolution or explanation. See the thread with this topic by Captain Bluebottle for 2 other reports.

If anyone can explain the likely cause of these errors. I'd be interested, otherwise, I'm computing. -kevin

DLaJuett
DLaJuett
Joined: 20 Feb 12
Posts: 6
Credit: 93653
RAC: 0

As I just noted in the other

As I just noted in the other thread "computation errors" - I and others have been having these errors only after installing BOINC 7.0.25. In that thread they suggested deleting BOINC and reinstalling. I"m going to try that soon as I get time, and we'll see. I never had any errors or problems until the BOINC upgrade. I dont know what else it could be, I doubt it's my pc.

5pot
5pot
Joined: 8 Apr 12
Posts: 107
Credit: 7577619
RAC: 0

@DLa I see you are using the

@DLa
I see you are using the 295 driver for your 520, are you crunching on it? If so when monitor goes to sleep, CUDA stops and cannot resume. Your output file shows no heartbeat for core client, which usually means your CPU may by overloaded. If you are crunching on all 8 threads + GPU, you will need to free up one thread for GPU crunching by telling BOINC to use 87.5% of your CPU.

Another possibility from BOINC website in regards to the error 1 code:

4. It happens on occasion that people see this error when they run a screen saver as well as use the GPU for calculations. Please don't use the (BOINC) screen saver. Your GPU is already busy with doing many calculations, it cannot show intricate 3D patterns on your monitor at the same time. Using a screen saver will also use lots of video memory that you cannot do without on doing CUDA calculations.

EDIT: I read your other post about you currently only crunch on your CPU. IF you are crunching on all 8 threads + doing other demanding work on desktop, I would reccomend bringing it down to using 7 threads, this will take some of the additional stress off of your CPU (no heartbeat usually means CPU is too busy)

5pot
5pot
Joined: 8 Apr 12
Posts: 107
Credit: 7577619
RAC: 0

@x00 Your computer may be

@x00 Your computer may be causing error 1 codes if you use this computer for general use while it computes, or if you are running the screen saver. Some older computers cannot run other tasks while crunching, otherwise the CPU gets bogged down.

Error code 2 on Boinc's website states that it may be caused by an error on your hard disk, you should use a program to check for disk errors, or as stated previously, if you are accessing files, playing music, etc., the computer is looking for file, but unable to find it with other tasks operating in time for BOINC task to continue on, and it fails after a certain amount of time.

Kyong
Kyong
Joined: 31 Dec 06
Posts: 2
Credit: 2041055
RAC: 0

I have the same problem. I

I have the same problem. I upgraded BOINC to 7.0.25 on some computers and all these ended with computation error. I tried clean reintall but nothing. I don't think, the BOINC client is good, some other projects do the same errors.

DLaJuett
DLaJuett
Joined: 20 Feb 12
Posts: 6
Credit: 93653
RAC: 0

Thanks. I reinstalled BOINC

Thanks. I reinstalled BOINC and this seems to have done the trick; no more errors, except just one, a few days ago, that was all. I read Moderator Bernd "Scotty"'s new post in Technical News about the GW S6 LVS 1.13 changes; this may be a factor, I am not sure.
(I stopped using my GPU some time ago. When I upgrade it to a GTX, Ill use it again). FYI note: I currently have BOINC Preferences, processor usage set to a max of 50% CPU time and use 60% of multiprocessors. I dont use the E@H, or, worse, the Seti@H screensavers much, as they do stress the GPU a bit. I dont really perform highly processor-intensive tasks when Im on the PC, though I do have Boinc preferences set to Run Always).

Bernd Machenschalk
Bernd Machenschalk
Joined: 15 Oct 04
Posts: 3640
Credit: 136874069
RAC: 43200

All I can say so far is that

All I can say so far is that getting client errors with exit code 1 ("incorrect function" or similar) seems pretty common with BOINC 7.0.25. This is not limited to a specific application, project or host; it appears to be a bug of the Client. If you are getting this and don't desperately need a 7.0 feature, I suggest to downgrade to some more reliable 6.x Client for now.

BM

BM

Ageless
Ageless
Joined: 26 Jan 05
Posts: 2943
Credit: 5374792
RAC: 0

RE: All I can say so far is

Quote:
All I can say so far is that getting client errors with exit code 1 ("incorrect function" or similar) seems pretty common with BOINC 7.0.25. This is not limited to a specific application, project or host; it appears to be a bug of the Client.


Yes, and therefore I flagged it with development already, they're looking into things. What would help is a client that shows a bit more information on what happens when exit code 1 is thrown, which is something we're going to get in 7.0.27

Jord

tullio
tullio
Joined: 22 Jan 05
Posts: 1920
Credit: 5246879
RAC: 3805

I am still using BOINC

I am still using BOINC 6.10.58 on my Linux box, no GPU. and running 7 BOINC projects, one with a Virtual Machine (BOINC_VM by CERN). On my Solaris VM I am using BOINC 6.12.26 by Dotsch,running a SETI@home app also by Dotsch.
Tullio

x002046
x002046
Joined: 23 Feb 12
Posts: 4
Credit: 2736202
RAC: 7343

Just to close the loop on my

Just to close the loop on my experience. After my second post indicating a completed wu, I experienced several more invalid function code errors and decided to roll back to 6.12.34. Since then I've processed 3 WU's with no errors.

Please note that the instructions for rolling back the 7.0.25 client indicate that you must delete two data files after the 7.0 uninstall because of the way the 7.0 client updates them which is incompatible with the prior client.

I have concluded that there may be other unidentified incompatibilities, possibly addressable with a change in the upgrade procedure OR there may just be a plain old bug. In either case, I have not had the time to test the "clean install" mentioned above (completely deleting the 6.12.34 before upgrading to 7.0.25) but it sounds plausible. I will continue to run for the time being with 6.12.34.

I do know - because I am a newbie and because it was my first upgrade - that before I originally upgraded I stopped receiving work, let existing work run to completion and report, stopped BOINC and then ran the 7.0 install exec. I did not uninstall the 6.0 client or delete any residual data or program directories or windows registry entries. I assumed the install procedure would handle all that.
-kevin

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.